Today is...
Sunday, April 23, 2017
Welcome to Control.com, the global online
community of automation professionals.
Featured Video...
Featured Video
A demonstration of EtherCAT control of linear motors using the CTC EtherCAT master.
Our Advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive
TwinCAT 3 Error When Switched to Run Mode.
TwinCAT 3 error when switched to Run Mode.

Hi,

I am new to TwinCat 3 and to PLC programming.

I made a program on TwinCat 3 to experiment a little bit. When I switched to Run Mode TwinCat gave me the following error:

Error 15 27/01/2015 23:23:48 551 ms | 'TwinCAT System' (10000): Sending ams command >> Init4\RTime: Start Interrupt: Ticker started >> AdsWarning: 4115 (0x1013, RTIME: system clock setup fails.
Hint: On Windows8 system execute win8settick.bat in TwinCAT\3.1\System as administrator and reboot.) << failed!

I am running TwinCat 3.1, Engineering eddition on Windows 8.1 64-bit operating systems.

Any suggestion of how I can solve this error is more than welcome.

Thanks alot

1 out of 1 members thought this post was helpful...

Hello

Check your Hyper-V technology. if it is switch on, just deactivate it in windows features.

By Martin Fahr on 26 March, 2015 - 12:10 pm

Hi,
I've got the same problem. Hyper-V is switched off. Running the suggested .bat file does not help.
Is it Ok to run Twincat on Windows 8 in 64bit mode?

Thanks for any help

> Check your Hyper-V technology. if it is switch on, just
> deactivate it in windows features.

By Yonatan Golan on 1 January, 2017 - 6:47 am

Hi,

I also have the same problem - Did anyone find a solution? .bat file doesn't help. I have no Hyper-V installed and I checked in BIOS and virtualization is enabled.

I have a Dell Inspiron 13 with windows 10 running on it.
Searching on the web I find many people complaining about this but very few answers.

Suggestions will be very appreciated.
Thanks!

Hi guys!

Just went through same issue and solved it by the help of a friend. Go to TwinCaT folder in your drive C:

TwinCaT>3.1>system there would be the file "win8settick" run it as administrator and reboot THAT'S IT

Hi.

I am totally beginner, so can you tell me what do you mean by reboot? I run the file as administrator and then nothing changed.

By MSK Stapler on 28 February, 2017 - 5:38 am

It basically means reboot Your computer.

> I am totally beginner, so can you tell me what do you mean by reboot?
> I run the file as administrator and then nothing changed.

I had the same issue but just followed the solution which was suggested in the error message. I've run the win8settick.bat as administrator and restart my computer and problem was solved. By the way, my operating system is Windows 10.