Today is...
Wednesday, November 22, 2017
Welcome to Control.com, the global online
community of automation professionals.
Featured Video...
Featured Video
Watch an animation of a conveyor stacking operation demonstrating the use of a move on a gear command.
Our Advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive
Schneider Premium TSX573 Series with PL7Pro 4.2 Program Corrupted
Our PLC for the Filter Process Control suddenly triggers a different output when you select an input, and we should expect an output signal from the output bus to trigger a relay to start a pump. What could be the best trouble - shooting approach?

Our PLC (Premium TSX573 Series with PL7Pro 4.2) for the Filter Process Control suddenly triggers a different output when you select an input. This has happen when we integrate it with Wonderware Scada. Although it has run for some time. The scada communicates with the PLC through Modbus, and some addresses were repeated meaning they might be triggered at the same time. We were supposed to expect an output signal from the output bus to trigger a relay to start a pump. We were running the program from the back-up PC but received error having communication issues time out. We tried replacing the CPU but still the same. The program resides in the memory card and maybe if we will replace it and reload new program might solve the problem. What do you think fellows?

By Bob Peterson on 22 October, 2017 - 12:14 am

I think the chances of getting a meaningful answer to a question like this is approaching nil. It doesn't seem like you have a lot of experience with this kind of thing. Probably your best bet is to find someone who has experience to help you. This may cost money.