Can No Longer Verify MODBUS String from Slave Device

I was using modscan software to verify I could read the registers from the slave device and I was. When all of a sudden I get a message The Mods can quit working and is going to close, it did.

After the program closed I couldn't establish communication again. I was at the device using a USB to serial cable with a null modem adapter. I tried a second MODBUS program, still no connection. What and we're could the issue be? Is the modbus software the problem or the slave device? I purchased both modbus software program, not trial freeware.

Any help would be greatly appreciated.
I don't know why a slave device would quit running.

I've run a licensed version of Modscan32 for over a decade, so I can't remember what happened when it expired when run in demo mode.

It sounds like you were running a demo version and it closed on you. I don't know whether there's a time limit (like 30 days or whatever) on Modscan.

I do remember that Modscan issued a license code that needed to be entered into a field.

Did you enter the license code? Help > About will show 'registered to" with a name if the license code was entered.