Can't install PL7 Pro/Micro 4.3 under Win XP Pro!!


Thread Starter

Gilles Hugues

I'm a french programmer, so sorry if my english is a bit bad...

I have a Toshiba P6050 notebook, running Win XP Pro SP1, a 20Go hd and 256Mo ram. I'm logged as administrator. Unitelway driver has been uninstalled. I have removed my antivirus and my hd is not compressed.

When I run the installation of PL7 (every version, i.e. PL7 Junior 4.1 ... PL7 Pro 4.3) i always have the same error:

The install goes well and when the installer tryes to install the functions family i have messages like "Error during installation of familly 1" and the install is not complete.

I have contacted the hotline, but no result, they only know that problem with compressed hd or antivirus.

Does someone have a solution? I don't want to reformat my pc and reinstall all applications (i have a lot).


Fernando Capelari

We have had the same problem here in Brazil.

There is a solution. Please pay attention on the procedure below before install PL7 in Windows XP:

"In the explorer screen , right click on the disk where you have to install PL7 PRO and choose properties . On the bottom of the windows , select " Allow Indexing Service to index this disk for fast file searching " . that's all . "

Genesio Conti

I' got another problem under XP and laptop installation : i use a USB to serial interface to communicate with RS485-232 adapter, but unfortunally PL7 ( ver 4.2 PRO ) don't recognize this adapter.
In other words, configuring USB adapter to COM1 port, PL7 don't run PLC's connection.
Is it this a bug, incompatibility or not ?
Are there cfg, detailed settings ?
Many thanks to all...
Telemecanique has a new cable to conect via USB with the TSX Micro/Premium. The reference is TSX PCX3030.

The solution with an adapter USB-RS232 doesn't work always. Some adapters work, but the communication is very slow and unstable.