Citect and DDE connection

  • Thread starter Fredrik Linusson
  • Start date

Thread Starter

Fredrik Linusson


I was going to get some values for Citect from one of our own DDE servers. Thought it would be a simple matter but no such luck. I keep getting time out errors and no connection. It alters between those two excusses but the point is the same: it can not connect to the DDE server.

Tried accessing our server from Excel and that worked fine. So I tried accessing the Excel DDE server from Citect. Nope, did not work.

Earlier today I also tried to connect to a Mitsubish FX0S without any success. The same error messages. Since Citect said nothing about the TX0S series but only FX1 and 2 and also said it wanted a SC09 cable when I have only a SC09, I just figured that might be why it did not work. But the DDE should work.

I run Citect in demo mode but that should work fine for 15 minutes as far as I know.

Anyone who knows what could cause this? Any settings I might have forgot, or something?

Fredrik Linusson

P&L, Innovation In Training
Box 252, S-281 23 Hessleholm SWEDEN
Tel: +46 451 49 460, Fax: +46 451 89 833
E-mail: <mailto:[email protected]>
Internet: <>

Eric Johnson

Fredrik, can you please supply some more information, like:

What version and service pack of Citect are you using?

Is the DDE server local or networked?

Are you trying to access the DDE server in Cicode are as an I/O device?

If in Cicode are you using the older DDE commands or the newer DDEh commands?

Do you have any real I/O defined? (If there are no real external tags defined in Citect then when in demo mode you can only access one DDE, API, OPC, etc. point.)


Eric Johnson
ACES, Inc.

I've used Citect with a SLC 500 before, using the DH+ protocol, ans came across a timing out issue. Now, it's been a LONG time since I used it, but there was a parameter to change the polling time in Citect. I don't know if anything like this is avaliable for the DDE protocol, but its just a suggestion.
Dear Fredrik,
The link with Citect DDE client is very simple.Probably You have made a mistake in the I/O device configuration. We have an example of Citect where Excel is DDE server and Citect DDE client. If You want it please send us an email with Your email address.

Best regards

Email: [email protected]