Communication between Sepam 40 and Citect SCADA


Thread Starter


Can you please guide me to understand how to establish communication between a Merlin Green S10MD power meter (Sepam 40) and a Citect SCADA system.

I have these modules:

Merlin Gerin power meter: S10 MD (Sepam 40)
Network Interface: ACE949-2 (2-wire RS485)
Merlin Gerin Gateway: EGX100MG (Modbus Serial to Ethernet Gateway)

I made the connection as follows:
From the power meter to the network interface (RJ 45) and from there to EGX100MG through Modbus serial RS485-2 wire connection.

I assigned IP Address to the gateway, and I have connection to the gateway through web browser and try to read power meter registers through gateway. I tried every Baud Rates (4800, 9600, 19200, 38400) and Every possible parity (Even, None) to connect to the power meter (S10 MD, Sepam 40). But still I have problem in reading data through EGX100MG Serial RS485-2 wire. The LED on the network interface (ACE949-2) is On and green (not flashing), and in EGX100MG gateway, the RS485 LED is On but the TX and RX LEDs (RS485 side) are off all the time. all commands to the available Modbus node (power meter) are failed with time out error. Do you have any suggestion to help me to connect power meter to gateway?
1. One never ever guesses at serial comm or slave node ID address setup. One reads the manual for the power meter and checks to see what the serial comm settings and slave node ID address are:

Slave node ID:

Baud rate: whatever
data word: 8 bits
stop bit: one
parity whatever

Be aware that some slave devices need to be power cycled (power turned off, then back on, after changing serial settings for the settings to be recognized.

2. One goes through the ethernet setup of the gateway, providing an IP address in the same subnet as the 'test' PC.
Open a browser (with a PC on the same subnet) to check that you can connect to the ethernet side of the gateway.

3. Then one goes into the gateway (with the browser) and sets up the gateway's serial side with exactly the same settings as the power meter has. No guessing.

Mode: master

Physical Interface: The power meter is probably 2 wire RS-485, but I haven't downloaded a manual and looked it up.
The setting in the gateway has to match for 2 wire or 4 wire.
Transmission mode: automatic

baud rate: whatever the power meter is set to

parity: whatever the power meter is set to.

Response timeout: 3

4. A suitable test of the serial connection is a read attempt by the PC browser connected to the gateway's ethernet.

The browser read function does not handle floating point, so one first reads the power meter manual and finds an integer value that can be ascertained from the power meter's display (so that you'll know you've read the right register or not) and determines whether that value is in an input register or a holding register and what that register address is.

Pages 14 and 15 of the gateway manual describe the 'read Modbus register' function using the web browser. I'd read one register to keep things simple. Use the register address you found in the power meter manual.

If none of the LED lights blink, then try swapping the two wires to the RS-485 on one end, it doesn't matter which end.

If the 485 wires are backwards, it'll never communicate, but it won't damage the 485 line drivers. It is a common issue with RS-485.

If the data value is not correct, try using a register address that is one less than you tried before, or one greater than you tried before. There's a one offset issue due to zero-based or one-based addressing.

Once you can read a register properly using the browser, use the Citect to address the ethernet side of the gateway.
Hi David,

thank you for answering, I checked every thing as u said, but the problem still exist. In the cabinet the connection from Sepam 40 (S10 MD)is through a network interface module (ACE949-2) and from there to EGX100MG gateway. Sepam40 module send data through a specific RJ45 Cable (CCA612: the CCA612 cord linking the ACE module to the Sepam base unit), but they used a normal RJ45 cable instead of it. according to data sheets I think that we should use this specific cable to be able to read data from power meter.