Connecting to CONTROLLOGIX 5561 firmware v12.42

I need to connect and upload a program off of a controllogix 5561 processor that has firmware v12.42 on it. I am working off of a windows 7 computer.

What I have tried/where I am at:

I'm working out of 'xp mode' on windows 7. We have the only local area connection working as a loopback adapter between the xp and win7 versions to handle the activation of rockwell software. This means we aren't able to connect to the PLC via ethernet. We tried adding another 'local area connection' but that does not seem to be helping.

We've explored the possibility of using a usb connection into maybe an en2t card or other processor but our usb ports are 3.0 which is unsupported by windows xp mode, and we've no clear way to downgrade them to 2.0. This further hampers us as we could be using the usb port to an external drive to handle our software activation and could then use the ethernet to handle the plc communications.

Has anyone handled this before? We cannot update the firmware without blowing away the program so we're kind of stuck.
I've never used XP mode to connect to a PLC. We use VMWare Virtual Machines instead. If you have a Windows XP Professional install disk and license, I recommend you use the trial version of VMWare Workstation Player to set up an XP Pro VM and install RSLogix 5000 on it. To continue using VMWare after the trial expires, you'll need a license. If you have a lot of machines you need to support in the long term, that's what I suggest you do.

You can also use VirtualBox to create a Windows XP virtual machine, but Rockwell doesn't support it, only VMWare.

We've run into the USB 3.0 problem as well and never came up with a solution. Even disabling USB 3.0 support in the BIOS wasn't enough for our older virtual machine software to use the 3.0 port. Thankfully, those laptops had 3 USB 2.0 ports too, so it wasn't a deal breaker. I probably wouldn't spend a lot of time struggling with the USB connection.

Do you need to use the loopback adapter with XP mode? The fewer things you have between your software and the PLC, the better. Have you tried just using the built-in LAN connection? Try disabling all network adapters except the one you're using to connect to the PLC after you open the programming software to get the license.

Once you have a working copy of the program, you can flash the firmware to the newest version it supports and use a newer version of the software installed on your host. If that's your only machine with an old firmware version, this is what I would suggest you do. The -L61 can be upgraded up to v20. Make sure you use the latest minor revision of v20. That particular major rev had compatibility issues with the lower minor revs. They fixed that with v20.4 (I think...).

Be aware, though, that your uploaded program will not have any comments or documentation. If the original programmer was kind and used descriptive tag names, you have a chance. Otherwise, your work is cut out for you.