ControlLogix processor problems


Thread Starter

Dave Campain

Hi All

Has anyone out there seen any problems with ControlLogix PLC's apparently caused by problems with the power supply or any other mysterious failures? One PLC we have used has had some strange behaviour. The symptoms are that the PLC stops communicating (by serial or Ethernet)and the program stops executing, but the run light on the processor shows that it is still running.. If the power is cycled the PLC returns to normal. On one occasion after restoring communication the processor showed it was running but the program was not executing (outputs not coming on). A loose wire was found on the power supply to the PLC and IO cabinet, and also on the power to the Ethernet switch that the PLC was communicating through. After fixing these the problem has not returned. The PLC was sent to AB but they did not find a problem and said that they have not seen this happen before. The PLC in question is a 5555 with V8.02 firmware.

It seems clear that a loose wire could cause some strange problems, but I need to be able to assure the customer that we have solved this issue. Without some feedback from AB or others that have seen similar problems the customer may not be convinced and still fear that there is some danger of future failures.

Dave Campain
We have install several (over 25 systems some with 5 or more CL processors)and have not had the problem you describe. We have use V2.51 to V10.0.
Do you have a fault routine? If so maybe the
processor had a fault and was in that routine.


James Ingraham

There is a known issue with early ControlLogix power supplies. The 110VAC adapters fail if the input voltage is over 150VAC.

From Rockwell Automation's "1756 AC Power Supply Product Service Advisory. ACIG 2001-07-001" :

The Purpose of this lett is to inform you of a potential functional issue that exists with:
1756-PA72, AC Power Supply, Series A&B
1756-PA75, AC Power Supply, Series A
when used with input line voltages equal to or greater than 150V ac. This issue does not affect installations wher the line voltage is less
than 150V ac.
Functional Issue - Thermistor May Fail in Certain Conditions.

Steve Myres, PE

I had one VERY strange application running v7.10 where the processor seemed to work properly, but you couldn't see across the backplane to
Ethernet and MVI (DOS PC) modules. They simply didn't show in Linx. The AB guys replaced the MVI module, Processor, Chassis, and Power
supply (some items more than once) before everything worked right. Some strange readings were taken on the Power supply, which was fed by a
UPS. To this day, I don't understand exactly what the problem was, unless they just had a rash of bad parts, or unless the power supply
damaged the other parts.

Gavin MacLean

I have had a problem with a CL processor refusing to stop. It would not stop from RSLogix, telling me the controller acknowledge my request to stop but was busy. I then tried to force the issue by putting the key in PROG. It still kept running for 15s.

This happened while testing how many arrays of DINT[125] producer/consumers I could exchange between two controllers. Once I powered down and downloaded the problem went away. I could only get 30 of these arrays at 100ms through ethernet BTW.


Gavin MacLean
Systems Engineer
Applicon Australia Pty Ltd [email protected]
Phone: +61 8 9353 6789
Fax: +61 8 9353 6790