Fix software and Commport.


Thread Starter

Sandeep Shroff

Dear List Members,

I have to collect certain tag information's from the intellution's FIX 7.0 software. I have developed an application in VB which is reading the data through DDE from FIX. After collection of this data I am transferring this information on a serial port using MSCOMM. I have tested this software with an in-house test set-up where the software is working perfectly giving the desired results.

I have tried deploying this solution at the site. At site there are 2 comports, one on which the FIX software is communicating to the fieldst server adevice on Modbus whereas on the second port a modem is connected which was being used for RAS ( remote access services). We have uninstalled the RAS hence the comm. port is free. Fix software has been started properly after removing the RAS. We have tried running the developed application on com port 2 after starting the Fix software. We are not able to access the comport as the application software is giving an error " Port already opened". We have tried running our application without the Fix software and it has started without giving an errors but we are not able to receive any data at the other end.

Is there any application / services preventing the access of comport ? is there any other task ( Alarm etc.. ) in Fix software holding the
access of the comport ? Has any body faced such a problem ?

Any pointers in this direction would be highly appreciated..

Thanking in anticipation

Sandeep Shroff
Sr. Consultant
Remote & Embedded Technologies
It does appear that FIX may be the source of the comm port problem, however you can try something else that may get you going in the meantime.
In your VB app you wrote, try using port 4 instead of port 2. You will still use hardware port #2, and your application may or may not work, depending upon whether port 4 is tied up somehow. This doesn't answer your question,
but may give you a workaround while you figure it out.

Sanjay Patel

Dear Sandeep Shroff

I have working with RS View 32, Fix-7 and experience of VB for communication. For RS view When we configure any driver in RSlinx it will occupy one of the com port so you can not access that. Similar situation may be in your case.
There are plenty of cards are availabel for expansion of the comport like Advantech, Nation Instrument, Quatech. I have worked with Advantech card and prepared the application which can collect data from 360 devices which can support modbus. Use this option if you have still any problem please give me more detail


Sanjay Patel
Dear Sir,
I am new to iFIX.I think I started working with it one week back. But for me it's surprising. There is no way a SCADA software can occupy the port for which it was not configured.

So check you VB code and check the Comm Port configuration.

Thanking You,
Sabapathy G
Project Engineer
Kalki Communication Technologies Pvt Ltd