Galil DMC-18x6 Linear Mode doesn't work

I use Galil DMC-18x6 with two ICM-2900 modules. In vendor original program (Optomec Work Station Control) I load minimal worked code like this:

Code:
REM Contours
VA 88200
VD 88200
VS 17640
LM YH
LI ,36505,,,,,,7091280
LE
BGS
AMS
If I remove first REM block or change first word "Contours" to another, program doesn't work. The axis goes to state "In motion" but actually nothing. If I keep this block it works correctly.

Then I put this program to Terminal (Galil WSDK) and load to controller. Block REM doesn't loaded to controller and I run this program with XQ command. The axis goes to state "In motion" but actually nothing. Command TS return "13, 141, 13, 13, 13, 13, 13, 141".

Another commands like PA, PR, JG work correctly from command mode and program mode.

What do I do wrong?
 
Contour mode is well described in OEM manual ....
It includes commands like CM/CT/DT/WC
Did you clearly understand way of Contour mode..

A drawing/sketch of the intended contour mode would be welcome here before to guide you on a solution
 
My friend
You are using command for linear interpolation mode with declarind Contour mode...something definitely not correct in this code...you got to review the right manual !
 
I tried to put EN instruction after AMS but this doesn't help me. And I look that it works from another software but I don't understand why?

This example was given from Optomec generator and minimized.
Actually I don't need Contour mode. The REM was generated from Optomec and works only in Optomec.
And yes, I read OEM manual and tried examples from here. Doesn't work for me.

Thank you.
 
Top