GE Mark V - Weird Time Issue


Thread Starter


Configuration is Mk V with Meinberg TC167 time card, all looks sweet. Time signal comes in and locks on. Meinberg config Page shows correct time on card and PC. PC time is correct, but alarm year is 2017 (its 2018). Logic force tools and Dynamic tool also show 2017 as the year. Same on both units.

Checking NTP config on slave unit shows offset of 31,559,99 seconds. (I think it is dropping a digit.) But basically it looks like somewhere in the system, we have a one year offset.

For the life of me I cannot find it nor explain it.
Also - everything looks fine according to the manuals.
Any ideas?

When did the problem start?

If you search the hard drive(s) of the HMI(s) you should find at least two TIMESYNC.DAT files. One should be in a folder called DATA on the G: drive and the other is usually in the root of F: drive (but having said that, we don't know what vintage of HMI(s) you have at site, and GE has been changing drive letters, because they can).

The file in the DATA folder will usually be the "generic" file, the "template" file. And the one in the root of F: drive will be the one that gets loaded when the HMI (or TCI) is started/re-started.

Compare the two files, and if you find any discrepancies I would start by re-naming the file in the root of F: drive (to, say, TIMESYNC.ASF (for AS Found)), then copying the file from the DATA folder to the root of F: drive. Then re-boot the HMI (or shut down CIMPLICITY then stop TCI, then re-start TCI and after a couple of minutes re-start CIMPLICITY (if it doesn't re-start automatically)). If this solves the problem, then all is good. If it makes a change, good or bad, then there's still something amiss with the Time Synchronization set-up.

I think there might be other TIMESYNC files, but I can't think of their file-name extensions right now. And, there should always be generic, template files for these kinds of definition files in the DATA directory to compare against.

Hope this helps! Please write back to let us know how you fare in resolving the issue.

Silly question as I don't see it in your original post. But if you are still using the old DOS or even the newer HMI, you can go to the command prompt F:/ and just type DATE and it allows you to set day/month/year.

Have you tried that?


I believe if time synchronization is enabled and one sets the date from the command prompt that in a short time it will be overwritten by the master time source.

It looks like TCI and the Mark V indeed have some offset. The most logical place would be in one of the time synchronization set-up/configuration files.

But, stranger things have happened, and when it comes to Mark* turbine control systems what was true at one time is probably not going to be true at a later time, and the way things were done at one time is probably not going to the way they are done at a later time. Progress.
Thanks for the assist guys ...

The issue started when we tried to get the local time card to work - it is a TCI167 and we are using the Meinberg software to do the syncing.

This unit has been down for a few years and we are returning it to service - and some one trashed the Meinberg time configuration.

While I have been tearing my hair out looking for this one year offset, nothing in the files seemed amiss and it all agreed with what the manuals were saying.

Our GE startup engineer arrived today and rechecked the setup. He agreed it looked ok ... and rebooted the master time HMI.

Magically, it all works fine now.

I forget who suggested the reboot - but you were in the money!

Thanks again.