Help with Xanbus protocol

  • Thread starter Jose Manuel Perez-Berrios
  • Start date

Thread Starter

Jose Manuel Perez-Berrios


I'm new to Modbus protocols, and I'm trying to communicate with a Xantrex communications gateway that has Modbus capability. I'm following the Xantrex modbus protocol manual (Xanbus protocol) along with LabVIEW Modbus libraries. So far, I'm getting either timeout errors or arrays of random bytes. I tested the ports and verified that data is being transferred from the gateway; therefore, I believe that is not the equipment, but rather something in the programming or communication.

If there's anyone that can help me with this, I would greatly appreciate it.

Thanks in advance,

Jose M. Perez-Berrios
[email protected]
Dear guy,

I have tried this before. And got the same problem as yours. The problem come from device security. It will not reply anything until you send the right passwords after device reboot. then it will reply anything you want.

Unfortunately, I cannot find the way to send password via modbus. You need to open device web page and send password there. or write script to send password via TCP/IP.

From my case , I got problem because My end device is Controller, there is no space to write TCP Protocol in there.

Mechanical Engineering, Silpakorn University, Thailand
[email protected]

Jose M. Perez-Berrios

Hello All,

I have completed the task of communicating with the Xantrex inverter chargers using LabVIEW modbus libraries and Xanbus protocols.


Ricardo Klein

How do you did it? It's because I can't connect to the Xantrux, all the time is doing the same error.

[!]: Winsock Error 10053 [Connexion has been reset by the client]
[!]: No response