Intouch Assertion Errors


Thread Starter

Paul Kelly

The info box that pops up contains an OK or Cancel button. Cancelling results in Windowviewer crashing, continuing allows windowviewer to continue, but we have a far from stable system. Intouch is connected to a DH+ network, via a
Sutherland Schultz SS5136SD ISA card, using RSLINX. We have also had similar messages relating to "...\vu_misc.c Linexxx".

Has anyone out there come across this problem, Wonderware's "solutions" to the problem (i.e. recompile everything, make a small change to all scripts and validate and save them again) have all proved fruitless.


Paul K

Control Systems Engineer
I have recieved that or simular message. If on a WinNT machine, Dr Watson visits. If on a WinNT machine with Visual Studio, Visual C++ will
activate, bring up that line of code from the executible View.exe. Luckily, this have never happened of the customer computer once the
design is complete.

Have you tried using RSLinx as a service? I always set my customers computers up to run RSLinx as a service, I start RSLinx manually on my design computers.

Are you using wonderware's wrslinx driver (or what ever they call it) to connect View to RSLinx (I don't, but may have on my "design"
computers)? IF connected using DDE, have you tried using the Direct or OPC connections?

Good Luck,

Thanks for the reply. I'm not running RSLINX as a service and instead of using the wonderware io server (WWRSLINX) all access names are
pointed directly to the RSLINX application.

However, RSLINX is not the problem (I think) as the system was originally configured to use the wonderware SST-5136SD IO Server, and the
problem was first encountered when the latest IO Server from the Spetember 2001 Wonderware IO Servers CD was installed.

I think the problem may be a corruption from earlier on during the development phase that has come back to haunt. At the moment I'm just
trying to aviod reconfiguring the entire PC.


Paul usually Assertion Errors come Application Corruption or bugs in the software (last one I remember was in the HD.exe). Can you use
Suitelink to the WWRSLinx Access Name(also check the version of WWRSLinx 7,5,0,1) and can you make sure you don't have advise all items selected.

Next make sure you have the latest patches installed for InTouch.

Last is to try to create another test application to see if it does the same. One window with some IO Tags, to try to replicate the problem. This will prove if its application specific or InTouch specific.

Dan Cooper