KNX - communication with MDT Glastaster II Smart

Hi everybody,

I am new here and this is my first new thread – let's hope I chose the correct category. :) I am a junior employee at a company developing software for industrial automation. Recently the KNX protocol was implemented into our universal application platform.
My colleague (another junior employee) and I were tasked with creating a model application using the KNX protocol. At this point, it isn’t really for commercial purposes. It's more of a test project for us.
We created the application with a simple interface and established communication with several “smart home” devices supporting KNX. Since our platform is written in Ada, we had to use our own special module to use the KNX Falcon driver.
Now finally to our problem and question:
The application works relatively fine, we can communicate and read data from several devices, however, we encountered a problem with the MDT BE-GT2TW.01, Glastaster II Smart.
We can communicate with the device, but we cannot use it to control the whole system. If we for example try to change the temperature settings through our app, the panel registers it, but still works with the previous temperature setting that was done manually using the touch panel. The same process works perfectly fine for controlling the Led strips. Overall the setting of the panel is not working correctly.
Does somebody here have some experience with KNX, or specifically with this device? I understand that it might be hard to advise if you are not familiar with our platform and application, but do you please have at least some general idea of where the problem is?

Thank you.

Try to read this video in english ! it can be an help!

Also can you tell us which app are you using as per the video it is using ETS software...

Any time!

Thank you so much for the response. I watched the video. From what I understood, it explains mainly how to turn ON/OF the lights. In our project, we controlled 2 led strips with the MDT device and it worked fine. That is one of the reasons I don’t understand why the temperature control doesn’t work.

About the application we used: The application is built on the universal application platform from my company. It's called D2000. It's used mostly for SCADA and MES systems but we wanted to test its use for smart home purposes (also for smart building control in power plants, factories,…).

My senior colleague worked out a way how to establish communication between our platform and the KNX devices. If it would help you to better understand the problem, he describes how he did it in quite a detail in this blog/article about KNX.

I and my other colleague were then given the task to create a simple app and test it. Everything works relatively fine. This is the screen from the ETS:
KNX D2000.png

When we used the same group address (7/3) for Numbers 11 and 12 nothing happened. So we tried to put it everywhere. Now, when we use our app built on the D2000 platform to change the setpoint (Group address - 7/3), it shows the new temperature on the display but the temperature in the memory stays the same.



Thanks for your inputs!

Here another video from same WebSite:

Even this support is in Deutsh, you can inspire from what is done by The narrator...

I see groupadressen window on this video and not in the screens shots that you got ...since you using D2000 I do not have access to this app so cannot state more on why the temp value not registered ...

Thats looks like there should be an holding register like "Modbus RTU"...

If you want to share D2000 documentation we could be in a better position to support in this case..