L2SFT Trip with Distilate Mode

Hi team,

Please I need help.

We have issue on gas turbine frame 6b, when we start with distillate fuel, we get L2SFT trip, after the ignition.

Thank you,
Best regards,
Hello Adem,

We don't have enough information yet but I will try to some interesting information extracted.

You should have a look on Operating & Manuals.

Here is some indication from GE manuals to help you:

If you are on Liquid fuel and if flow divider speed FQL1 is higher than constant LK60FFLH FOR K2SFTL time In liquid fuel, turbine trip is intiated whenever fuel flow is high after completion of warmup, accelerating stage and no liquid fuel recirculation Trips when the firing timer, K2F, expires and when flame is not detected from 2 of 4 flame detectors after giving start command K6TT2 times and on total gas. ACTION SETPOINT (Nominal Setpoints) L4VS4_PI PRE IGNITION Prevent failed start caused by loss of gas flow 33VS4-1, 2 NA Startup Fuel Flow High L2SFT PROTECTIVE STATUS TRIP 2 Prevent excessive fuel caused by valve control failure at ignition Gas: 96SR-1,2 Liquid: 77FD-1,2,3 See Control Spec: LK60FSGH = 20%,LK60FFLH=14% Failure to Ignite on Gas L94FIG L4FIGFLT PRE IGNITION TRIP L4PRET Prevent excessive fuel caused by.....

Again I think that you should begin by have a look on these datas.

Best luck
Hi Adem,

Again i Would suggest you to have some trends and view from the signals existing in the logic of the liquid fuel flow command.

Looks like you have excessive fuel flow during start up....

I have a power point with me explaining the rca of such trip you got

Here is the link :

Hope this will a help for starting troubleshooting.

For sure you will have to get some trends in order to fiind out what can be the RCA of the unit trip.

Best regards,

We tried to start GT Ge frame6B on destilate mode (Mark VIe control system), when we reached firing speed, flame detected on 2 FD. And we tripped by L2SFLT. I checked Triplog trend, FQL1 and fqrout, I found that fqrout is 3%, and FQL1 increased to 25% then dropped to 0%. After that we tripped by excessive fuel L2SFLT. I tried to start again, we tripped by failure to ignite.

FYI, the turbine was running before on gas without issues, and we can change it to destilate after FSNL.

We replaced AA booster compressor outlet check valve.

Thank you.
Hi ControlsGuy25,

Thank you for your help.

I have Triplog trend if you want to share it with you (send it to your email or ???).

The GT working on gas and we can change it to destilate or MIX mode without any issue, but we couldn't start it on liquid fuel. We started it since 9 mounth ago and worked fine. So, yesterday, the first startup test, we tripped by L2SFT (one detector detect the flame for a few seconds, and the seconde test we tripped by failure to ignite.

Thank you,
Hi Adem

How is things at your side?

I know that transfer from gas top liquid can be sources of issues some times. I experienced that issue in one site with units using Naptha and benzene distillate.

Yes we can exchange via email. You can let your email here and I will try to have a better picture of the non successful Gas to liquid Transfer that your unit is facing now.

PS: I am actually on an short assignement but will be glad to try to give you some support as far as i can.

The team here is fantastic for giving support .

As we say in french " Bon courage pour la suite".

You can also drop me an email to this adress:
[email protected]

Speak to you soon,