Mark VIeS Virtual Controller Pcode Error

Peace everyone

So i managed this 6 months to learn how create a virtual controller and create a simulator for some MK VI and MK VIe projects (which are provided by the simulations blocks)

And recently i am trying to do this with a MK VIe and MK VIeS projects, i configured the both virtual controllers and prior the network configuration, i managed to download the baseload and the firware and application code on both. after that when i started them, the MKVIe VC was running normally however the MKVIeS VC showed an error saying "block serialize error" "Pcode serialize failed".
i tried a different project, with the same MKVIeS VC version, the same error, changed the VC version, the same thing.
i wonder if i am missing something here, so if anyone has an idea please help.

you can find the screenshots in the links below :
Interesting; the best possibility I can think of is that the Mark VIeS virtual controller version doesn't match the runtime version used to configure the device in ToolboxST. The block libraries are built into the simulator rather than accepting a download from ToolboxST like the real runtime, so any differences in the blocks or their pins can cause the pcode serialization issue you're seeing.

If that isn't it, my best guess is a bug in ToolboxST's pcode generation, in which case you should submit a bug report (from the Help menu in ToolboxST). They'll need a copy of your controller configuration to debug it, plus details on versions (in fact, I'd use the Versions tool installed by ControlST to generate a complete install list and include that in the bug report).

Hope that helps!

I would double check the Simulator and Toolbox version to make sure they are compatible. Also, I would changed your controller type to UCSBS1A (if you have a later version of toolbox). It looks like the simulator is having problems with some specific type of logic. Try to delete it in the code, then re download.

Send me a follow up email if you want to go into more detail. [email protected]

thank you for your reply, i will try to find an other version of MKVIeS virtual controller. i do believe i need an earlier one, because i tried a later versions than the one showed in pictures and i had the same issue. will keep you updated with the situation as soon as a progress is done.

Thank you for your reply, i think the problem is the simulator version, because i tried a later version of the simulator and had the same issue. i think i need an earlier version, because the version of the MarkvieS is V03.02.07C.

For the point of deleting the specific blocks, everything went normal. however, i was obliged to deleting a huge part the code to make it happen.
Ah, if your Mark VIeS version is V03.02.07C and the Virtual Mark VIeS version is V04.03.00C or later, that might explains things. Between the two versions two pins were added to the COMPARE block (HYST and SENS), and given the serialization failure was in a user block called BLOCK_COMPARE_R. I'm guessing that is the issue. An older virtual controller version (preferably the same as the Mark VIeS product version you're using) should work.

Still, ToolboxST shouldn't download an application build with an old runtime version to a newer virtual controller. I've submitted a bug report on that for you.

Yes! it is exactly like you explained. i could manage to fix the problem yesterday by finding and using the proper virtual controller version V03.02.37C and everything works fine.

thanks again for your contribution!