Micrologix 1400 Thermocouple Input Module not detected


I'm new to Allen Bradley programming and found a problem while configuring my hardware. I have a Micrologix 1400 Series B CPU, one digital input expansion card connected on slot 1, one digital output expansion card connected on slot 2 and a Thermocouple input card on slot 3. Problem is on RSLogix500 IO configuration, the Thermocouple input card is not detected. Is there a way to correct this or the module is faulty?

Page E2/3 describes configuration - have you got RSLogix500 version 5.50 or higher ?
Can you manually select the Thermocouple input card for slot 3 as shown ?

I have RSlogix500 version 11.0.0 and I can manually select the thermocouple input card in IO configuration and verify the file but when I tried to download it to the CPU, it shows an error that the thermocouple module is not detected.
Also I have noticed that the thermocouple module have a power indicator, will it light up even if the configuration on RSlogix500 is not successful? Currently it is off even if it is connected on slot 3
One would have thought download would continue without the Thermocouple input card and come up with resetable error thereafter.
Have you tried the combination, download with card in place then take the card out once system configured.

Unsuccessful configuration on RSlogix500 will not energise the thermocouple module power indicator.

I have tried to download the program with the card in place and select the "Ignore Configuration Error". With this, I haven't encountered an error but I am not getting any reading from the thermocouple connected. Also when I tried to select the Read IO Config from IO configuration, the thermocouple module is not showing