MKVIE UCCC Not Booting

Hi everyone,

From yesterday we have one controller OFFLINE (Controller type is IS215UCCCM04). At the front of power supply, the LED power is solid green: alarm LED is off which means no PS Problem.

On the CPU Front view Status LEDs we have:

power: is solid green.
System: in Solid Red and doesn't turn off.

Looking into the help, System's LED should turn off when CPU is ready! Seems that our CPU is not.

I tried a Reset through RST Reset button. Nothing was happened (except that during reset operation RESET LED turns on in Blue color).

No UDH Communication (no respond to ping command remotely).

For IONET Communication no LED active on CPU side, but the LEDs are active on IONET side. When unplugging IONET ethernet cable R, S, T, I saw their LEDs become off respectively from IONET Swith side.

I suppose we have something to factory reset of the controller prior thinking of change it, because we have a COM1 port for initial setup of the controller. If this is right please share procedure for controller's initial setup, and cable specification (its a kind of RS232 C with RJ45 connector).

Many thanks for your suggestions.
There is information on serial cables and COM settings in GEH-6808. But if you've got a UCCC, its possible your ControlST version is so old this document wasn't written yet. In that case, you need a standard ethernet cable and an adapter that converts to a standard serial port, GE part #342A4944P1 for a UCCC. I don't know where to get one other than GE. Port settings are 9600 baud, 8bit, no parity for a UCCC.

Hope that helps!
Definitely sounds like you have to re-flash the controller. See Demigrog's comments.

Another stupid question: is there a flash card in the UCCC controller? If there is not, then this could be the reason the UCCC is not booting up. Or the flash card could have been corrupted on reboot. But I find that very very unlikely.
Thanks guys,

However temporary I prepared another controller (spare). I used the older Flash Card taken off from the older faulty controller, now its okey, with new controller. The unit is again online.

However, since I'm convinced that the older controller is not hardware damaged, now I'm looking for the cable specification, as Demigrog mentioned, that's great with the Part Number (we need to purchase one).

But actually I'm looking to how to make it myself with UTP CAT4 Cable, RJ45, DB-9 connector...if someone have an idea.

Thank you for your suggestions.
There really isn't any configuration for a Mark VIe that isn't stored on the flash card; if the card from the old controller works in a new one, the old board probably has a hardware problem. It isn't necessarily unfixable, but your mileage will vary. A lot of times the CF connector itself is the culprit, and merely re-seating the card fixes it. Sometimes the original problem was power or grounding, and the problem was fixed accidentally while replacing the board. Don't get your hopes up though.

Other than setting the IP address from ToolboxST and seeing more detailed information during boot-up, there isn't anything you can do with the serial cable. I can't find any documentation on the pin connections, though I do know the serial adapter for the UCCC is not compatible with the adapter for the newer UCSA/UCSB/UCSC controllers, so there must be something variable in them.
Unfortunately not yet, I'm always working on the issue.

One of GE documents says the following:

"Two micro-miniature 9-pin D connectors:
COM1: Reserved for diagnostics, 9600 bauds, 8 data bits, no parity, 1 stop bits.
COM2: Not in use.
For cabling use one the following:
1/ Standard four pair UTP (ethernet cable) joind with a PC null Modem connector, (GE Part #342A4931ABP1) and a controller connector (GE Part #342A4931ABP2).
2/ a miniature D shell, null modem serial cable ( GE Part #336A3582P1), connected with a micro-miniature pigtail (GE Part #336A4929G1)."

Unfortunately I didn't find such PC null modem in our storehouse, I'll try to ordre the appropriate device trying to connect and surely to re-initiate the controller.

All suggestions from you guys are welcome.

You don't need the serial cable to re-flash a UCCC; you just need a compact flash reader, ToolboxST, and your configuration files. ToolboxST can build the initial flash configuration and set the IP address. Then you just plug in the CF card to the UCCC and boot it up, and it should just work. I don't have the documentation in front of me, but I'm sure there is something in GEH-6700 on how to do this.

Beware some cheap CF readers don't seem to work reliably for this, I'm not sure why.
Dear Demigrog2,

I think you mis-understanding.

the originally issue, please refer the original post. as I mentionned before this is not a problem of CF. as I said before, I took off the CF of the older Controller I inserted it on a new one. it worked fine, without any setup of IP or whatever (through downloading as well as boot routine, software...etc).

I read that somehow we can factory re-initiate the controller, this can be done through a serial cable from the COM1 in front side of the controller.

This is a kind of cable with DB9 connector (with a null modem adapter) at the end and RJ45 connector at the other end.

I'm asking if its straight or crossover cable? Or even if its special cable? And after connecting how to use the ToolboxST for the initial setup of the controller?.

Thanks for sharing your experience.

>I took off the CF of the older Controller I inserted
>it on a new one. it worked fine, without any setup of IP or
>whatever (through downloading as well as boot routine,

I'm pretty sure none of us understand the "problem" you are trying to describe. Do you just want to access the UCCC card via the serial port just to do it? Because, if everything worked perfectly when you swapped the CF (Compact Flash) card to the new UCCC, then it would seem everything is okay.

Do you think you can "re-initiate" the "old" UCCC card and possibly get it to work again using the serial port/cable? Because, I don't think that's going to work. If the CF card worked on a new UCCC and it didn't work on an older UCCC, then it's pretty likely the older UCCC is dead/broken.

GE typically uses null modem cables for serial ports, have since the Mark IV days. So, if you buy a miniature D-sub assembly (I don't recall if it's make or female) and configure it to work with a serial port on a PC (desktop or laptop; if you use a USB-to-serial adapter be aware that many of them do not work well with ToolboxST, if at all!) you can connect it to the UCCC and try to access it. It won't hurt anything if it's a straight-through assembly and the UCCC/ToolboxST requires a null modem, or the other way around. If it doesn't work one way, you can reconfigure the cable to be the other type. Again, it won't hurt the UCCC or the PC if it's not configured correctly.

And, if you're working with a USB-to-serial adapter on the PC, we WILL NOT be able to help if the assembly you built doesn't work. There is entirely too much variation in the chipsets used for USB-to-serial cables, as well as the software drivers. So, your cable may be just fine--perfect; but how will you know if it's the cable or the USB-to-serial adapter? We won't be able to help with that.

There's nothing special about the adapters, except that GE doesn't really want to sell them (based on the price they charge for them, they really want to keep them sitting in their warehouses on their shelves!). I have built my own serial cables for working with GE Speedtronic/Mark* products since 1984 (when I didn't know anything about serial communications). Lots of trial and error, and I never damaged a PC serial port or a Speedtronic/Mark* component.

Again, if you're trying to "resurrect" a non-working UCCC with a serial cable because of your understanding of something written in a GE manual--it's probably not going to work the way you think it will or should work. If the card is "dead", it's not recoverable via the serial port.

Demigrog2 can probably comment or clarify, but it's my understanding that using the serial cable is just one way to set the IP address and get some basic information <b><i>to the CF card</b></i>. If the CF card you removed worked when installed in a different UCCC card, then using a serial cable on the "old" UCCC card isn't going to make the old UCCC card work. You might be able to access a new CF on the old card, but if the old card wasn't working, a new CF isn't going to make it work. And, one more time--if the CF card from the non-working UCCC card works fine in another UCCC, it's pretty likely there's something wrong with another circuit/component on the non-working UCCC card.

Best of luck!

I did have one more thought after looking through GEH-6721, Vol. II (Rev. F). There have been reported problems with UCCC cards related to dead batteries on the cards.

Have you tried replacing the battery on the UCCC, then re-installing the original CF card, and re-installing the card in the CPCI rack and booting it up?

Can't hurt. (And it's a lot simpler than making up or persuading GE to let go of one of their cables (by giving them a LOT of money).) Those cards were pretty robust, almost bullet-proof, as I recall. GE stopped using them because the UCSx cards didn't require the CPCI rack and power supplies, and took up a LOT less space in a control panel enclosure. (The UCSx cards were probably significantly cheaper in the long run, too, as far as assemblies go.)

Hope this helps!
Whether re-configuring the Flash card or Using the Serial cable to configure the controller. Both ways do the same thing: it assigns the IP address to the controller and gets its base information so that the UCCC can startup and be ready to receive a real download from ethernet. So as Demigrog2 says, you can also use the flash card method...but you are correct, it seems to be an issues with the controller, not the flash card. So, you may want to investigate what Failure issue it could be. If you have access to the old GEH-6721, this will tell you more info on the UCCx controllers Version K or L will work.

If you want to configure the UCCC controller via the mini Serial cable, make sure that you have a Flash card in the controller (128MB use the same type from the other controllers).

If you controller does have an RJ45 Com port, then yes, you need to use a 9 pin serial to RJ45 Null Modem Adapter... this should plug straight into your 9 pin port on your computer.
There is no "factory reset" via serial cable. At best you can get more specific failure information while it is booting. The "factory reset" is reformatting the flash card using ToolboxST. There isn't anything else on the UCCC to configure except the BIOS clock (no other settings in the BIOS are configurable, specifically to eliminate the battery as a failure mode).

If the controller boots normally, you can set the IP address via serial cable, but that is literally the only change you can make unless you want to log in to QNX and start messing around on the command line (assuming it boots that far). That can be kind of fun, but not terribly useful. :)