Modbus basic questions

Hi all,
This is my first post since joining the forum. I have worked in the hvac industry for 16 years swapping many bms components and a time served refrigeration engineer and now have been trying to further my knowledge of the workings behind the scenes.

I've a modbus rtu setup for testing, I'm trialing a connection to a mitsubishi electric frd700 inverter direct from my desktop via an rs485/USB converter on comm3.

I can interface with the drive via modscan64 and manually alter the binary registers to signal the drive to run, stop and vary the frequency etc. No problems.

I have a trial of quickhmi, I have setup the data source correctly but am struggling to communicate with the drive. Slave id , baud rate, parity etc all match modscan64 settings. The drive is set as a slave in the hmi. The register I'm trying to access is hr 9 (40009) I'm referencing it as hr8 with a byte variable type. Then trying to write the hex conversion of the new binary byte to the register.

Any advice would be helpful!
The register I'm trying to access is hr 9 (40009) I'm referencing it as hr8 with a byte variable type.
I've never used QuickHMI, but it would seem to make sense that if you want to access Holding Register 9, then you would reference it as hr9, not hr8 (unless QuickHMI uses 0-based addressing instead of 1-based). More importantly, though, Modbus registers are 16-bit integers, so you should be using the "Ushort" variable type, not the "Byte" variable type.

You don't mention what the actual problem is. Are you unable to communicate to the VFD at all from QuickHMI or are you getting some sort of error?
Thanks for the reply, I've changed the variable type as suggested. And the register address to the actual.

It does not seem to communicate at all, as before the modscan can see the slave and read /wrote to the registers. So I can reliably say the communication link is OK.

I have tried to simply read a register that I have altered directly on the inverter to a number value of 609, the quickhmi doesn't read it. In the text field it reads as zero. I've tried integer, doubles etc but no joy.

It's a head scratcher...
The HMI’s serial Comm settings have been configured to match the drive?

Try swapping the Rs-485 driver lines on one end. Some vendors label the (+) and (-) lines the opposite of other vendors.