Modbus protocol Serial RTU cannot write registers.

Hello Everyone,
I am trying to communicate via Modbus protocol with a uC2 SE Carel controller. For that, I am using softwares like ModScan and Tester, as well as minimalmodbus code from Python. With all of them I can only read registers, but cannot write them. Also, softwares response seems to be right with no errors at all. Here, I show a bit of code and response read by Python. Any help with this, am I missing some permission for factory parameters? ? Thank you very much in advance:

COOLING_SETPOINT_REG = 41
NEW_TEMPERATURE = 20.1
instrument.write_register(COOLING_SETPOINT_REG, NEW_TEMPERATURE,1,functioncode = 6)

20.0 MinimalModbus debug mode. Will write to instrument (expecting 8 bytes back): '\x01\x06\x00)\x00É\x98T' (01 06 00 29 00 C9 98 54) MinimalModbus debug mode. Opening port COM8 MinimalModbus debug mode. Clearing serial buffers for port COM8 MinimalModbus debug mode. No sleep required before write. Time since previous read: 47.00 ms, minimum silent period: 4.01 ms. MinimalModbus debug mode. Closing port COM8 MinimalModbus debug mode. Response from instrument: '\x01\x06\x00)\x00É\x98T' (01 06 00 29 00 C9 98 54) (8 bytes), roundtrip time: 47.0 ms. Timeout for reading: 1000.0 ms.
 
Make sure you are targeting the correct register. Some Modbus masters (such as ModScan) use 1-based addressing, while others (such as the MinimalModbus library) use 0-based addressing. For example, for the Set point, you would use 41 in ModScan, but use 40 in MinimalModbus (this assumes the Carel controller's documentation uses 1-based addressing).

Additionally, from the Carel controller's documentation, the MIN and MAX values allowed for the Set point (r01) are determined by the Minimum set-point (r13) and Maximum set-point (r14) settings. Please check the values of r13 and r14.
 
I have tried to write on some registers and also coisl (write_bit) without success. The problem is that no error message is back, simply values remain the same. You can properly read them, so by using same register number I can verify which one is, and this happens with every software that I tried. Thank you very much.
 
Good idea to try writing to other registers and coils. It seems like you're doing everything correctly, and as you've seen, Modbus communications makes it appear that everything is working correctly, since you're getting valid responses back instead of exception responses.

I think you need to contact Carel. Perhaps, as you initially thought, there is some type of internal permissions setting for writing from the Modbus network.
 
Top