No Connection RS485


Thread Starter


Hello all,

I am having an issue. I am trying to connect to a controller that has an RS485 connection.

The controller is a Hired Hand Evolution 3000.

I am using a RS485 to USB adapter for my laptop. I tried running CAS modbus scanner. I selected the COM port and as well has the rates. I set the controller to address 1.

When ever I try to scan it says connection failed. I double checked my wiring even tried crossing the wires. Still nothing. I went through and tried different baud rates and hex/ascii and RTU. Still nothing.

So I launched the companys software the comes with the Controller for connection to a pc and it load just fine.

But for some reason when i try to scan with CAS Scanner i get nothing.
RS-485 is just a transport mechanism for binary bits. Any number of protocols, sets of rules for communication and how data is packed can run over RS-485.

I seriously doubt that the communications protocol is Modbus, therefore, using a Modbus master utility won't do anything.

A Google search brought up only one manual for the Hired Hand Evolution 3000. A search of that manual does not hit on any of the following terms:

The daisy chain 3 wire comm link suggests that the digital comm hardware layer is, likely, 2 wire RS-485. But given that Modbus isn't mentioned, nor is a Modbus slave table provided for data registers, it's unlikely that the communications is Modbus, hence the CAS Modbus utility will not work.