Notebook COM1 - ALLEN-BRADLEY 1747-PIC


Thread Starter

Troels Christensen

Hello List

I have a problem connecting my Chicony Notebook Pentium III 450 MHz running RSLogix500 together with a SLC 5/03 using the 1747-PIC box.

I don't have the problem with my old Notebook

I think the problem is the Com1 but i am not sure.

Any ideas?

Thanks to all in advance.

Troels Christensen / [email protected]=09
HOH Vand & Milj=F8 A/S
What kind of problems do you have?
Is it with RSLinx? RSLogix?
Do you get at error?
You might check and make sure that you PIC driver is configured correctly in
RSLinx: correct Baud rate etc.


Scott Brown
Gemtron Corporation

Brian Peck Northeast Utilities


I have had problems in the past where some laptop serial ports do not work well with some devices. Specifically, a Black Box brand 232-to-485
converter would not work on an IBM Thinkpad, but would work on a Dell desktop. Black Box made a different model that utilized a separate power
supply which worked reliably on the laptop.

Brian Peck
Northeast Utilities

Leighton Toews

Hmm well, kind of a lack of information there... If you had a serial mouse connected to com1 and then unplugged it to jack in the PIC then this problem would exist... You have to reboot without the serial mouse connected... without more info that is about the best "idea" I can give you :)

Leighton Toews
Process Control
Del-Tech Industries

C. Thomas Wiesen

Start by connecting to the PLC with a serial cable only. This will test to see if RSLinx is working with RSLogix and will also confirm that your serial port is operating properly. If this works, look at the configuration of the DH-485 port on the PLC and make sure that nothing is setup improperly. If this doesn't work, you can test your COM port by connect a null modem cable between your laptop and another PC and use
Hyperterminal to type characters to each machine. This will tell you if the port is operating properly. Also "Pin out" the DB 9/25 adapter between your laptop and your PIC (I have had problems getting the correct 9 pin to 25 pin adapters) and verify that you have the correct
adapter and that it is working properly. You can get the proper cable pin outs from the Hardware Configuration Reference Manual (9399-HDWAREREF) which can be downloaded as a PDF from the Rockwell Web site ( "": ). If none of these are the culprit, it is likely the PLC port or the PIC module.

R A Peterson

I received the following info from Rockwell Software regarding using thier DOS software in Windows NT

Here are answers to your questions about DOS product support in Windows NT.

AI-2: v6.25 runs in NT. Communications options are limited. You can use the smart serial cable (P/N 9399-L2103) direct driver or RSLinx with the PCMK on DH+ to a KA3 connected to the PLC-2.

AI-3: v6.22 and higher run in NT using RSLinx or the direct serial port drivers.

AI-5: v8.x runs in NT using RSLinx or the direct serial port drivers.

AI-500: v8.x runs in NT using RSLinx for everything. The PIC driver apparently isn't extremely reliable.

PDS: Not supported. PanelBuilder32 is supported, however.

SLC100: Not supported.

Messagebuilder: Not supported. It's written for and works only in Win3.1.

Andy Piereder

Try the obvious first: Check whether you are using the right COM port.

Check the cable. Are you using a null modem cable? If not then 'clear-to-send' won't be asserted. A null modem cable cross connects the
pins doing the handshaking during half-duplex operation.

If this still doesn't work, you can test your serial port by launching a program like hyperterminal and shorting the TX and RX pins (2 and 3) with a paper clip. What you type should be echoed back to you if every thing is in

If that doesn't work you need to take your PC in for service.

Andy Piereder
Pinnacle IDC
I came across an article at the Rockwell support
site (I don't know the url but I'm sure I can
find it again) that basically said the PIC driver
is very fussy about which chip the COM port uses.
If you don't have the normal chip, then they
suggested adding another port with the correct
chip or purchasing an A-B ($$) card.

Hi Troels

Some Laptops use 0-5 V Signal levels on their COM Port instead of the +-12V as per Standard. Your PIC might not cope with the lower levels.

Cheers Rolf
RG Electrical Engineering & Consulting
2 Little Street, Fannie Bay NT 0820
PO Box 37601, Winnellie NT 0821
Tel: ++61 (0)889 413 945
Fax: ++61 (0)889 419 280
Mobile: 0417 837 933

Allen Bradley System Integrator
Rockwell Strategic Software Provider

Jerry Miille

I have a similar problem with my PIC and an older laptop. The problem is that the PIC is powered from the serial port of the PC and if the PC is not plugged in, there is not enough drive out the Comm port to reliably run the PIC. Plugging in the battery charger solves the problem on my machine.


Jerry Miille

Miille Applied Research Co., Inc.
Houston, Texas
[email protected]

Marc Sinclair

Try connecting directly, the 5/03s that I use allow connection directly with RS232.

marc sinclair

Scott Jensen

A major problem with running AB devices from COM1,
has to do with the mouse driver. Unfortunately, the mouse driver looks at COM1 for the mouse also and the is something about AB comms it likes. Things tend not to work... The only way to keep it from looking is to edit COM1 out of the mouse's registry entry. There is some help how to do this if you dig around at the MS mouse drivers section at the MS web site.

Scott Jensen
[email protected]

Ranjan Acharya

Re: ThinkPad and PIC.

The problem is the way the new notebook BIOSs APMs (parts of which cannot be disabled according to IBM) handle the power to the serial port. We have had similar problems with older versions of PLC programming software (with no external programmers -- just a straight serial connection from the serial port to the PLC).

This brings up the same problem that the list has mentioned before -- older software (especially 16-bit or early 32-bit applications) and software with dongles or programmers and software with early versions of copy protection. A lot of it just will not work on the newer laptops. We spend a lot more time keeping our legacy applications working on the newer laptops.

Ranjan Acharya 905-634-0844 x 238 (V)
Team Leader - Systems Group 905-634-9548 (F)
Grantek Control Systems
[email protected]
[email protected]

Anthony Kerstens

This problem is not limited to ports. I once had a laptop where if the battery was having problems with "memory" and would not fully charge, the harddrive controller would not function properly.

Solution: new nicad pack once in a while.

Anthony Kerstens P.Eng.

Morten Nilsen

A good answer, unless you have something else, such as a radio modem connected to the PLC RS232 port.

I had connection problems using a PIC with a Winbook laptop. RSLogix (through RSLinx Lite)
would connect to the 5/03, but lose comm within a few minutes. The solution was to disable power management both in the BIOS and in Windows 98.

Morten Nilsen
There is a MAJOR problem rslinx accessing the serial port. The problem shows when you have a laptop that goes to access the the com port and the windows system is sharing the com resources. RS Software does not know how to properly request the port in a windows environtment (from what I can tell.) My problem was that the pcmcia slots were sharing the irq resources. Do the following. Check the configuration, under windows, to be sure that the resources are not being shared. Then, under the system bios, be sure that you specify the port settings both here and in windows. do NOT let it used automatic settings under either of them. Marc. Question... is there a decent pic box replacement out there?
Jerry, The PIC module is powered from the PLC and not the COM port. With any type of power management on the computer, the COM port basicly gets powered down, or shut off loosing communication with the PIC module. For best results, disable power management on your laptop.

Kari Swimelar
Technical Electrician
KJC Electric Inc
1516 Union Ave
Belvidere, IL 61008
(815) 544-6551

Lynn at alist

Yes, it may also just be a side effect of modern notebooks - their TX line tends to go "+" when the port is "off", meaning no application is intertested. Running this thru a UART to a micro-controller gives the controller a constant BREAK condition on TX. I have seen some CPU don't like this (AMD188/186 for example) if they are booting and it can cause the CPU to fail to start up. I'm not saying this is an issue with the AB/1747-PIC, just something to watch out for anytime an intelligent device is attached to a notebook & you expect it to run when no application in the notebook is interested in it.

- LynnL,
Yeah, it's called a PCMK card, lol.

We use them ourselves but our customers almost always want to go the cheap route and buy a PIC adapter (especially when skimping and buying the SLC500 w/no serial port). Where the PCMK cards are reliable and versatile, getting the PICs to talk seems like more and more of a chore.

Also, the more AB I see the more I appreciate Modicon.