RSLinx & multidrop AIC's to PC's


Thread Starter

Steve Stirrup

I have an SLC5/05 using RS485 on channel 0 connected to a Net AIC module, with two PC's, running Win2k, connected to two other Net AIC's.
I've tried using the PIC driver on RSLinx (V2.30.01 & V2.30.02 candidate both tried) on the 2 PC's but they do not pick up anything on
RSWHO. I've followed all the Rockwell KB articles about PIC driver problems and still the driver shows as STOPPED in the driver config

Also, does the comm port on the PC need to be configured as 485 or 232? (Jumper settings on one port give us this option)

Any help greatly appreciated.

Try first deleting all configured drivers , then add again the PIC driver and check if it does run this time, make sure it is configure for
the right comm port on your PC (comm1 or comm2). As far as messing your comm and change it to RS485, you shouldn't have to do that, leave it
with 232.

Marty Vander Plaats

Getting the PIC driver working under Win2k can be a problem. Power management can screw it up. If you don't mind my asking, is there a reason you are trying to use serial on an SLC 5/05 instead of Ethernet? The ethernet port is extremely fast, and fairly simple to set up.
I've deleted the driver whilst running linx as an app (not service) and reinstalled and it makes no difference.

The com port is disabled (as this is the only way it will run) and the driver has exclusive use of it. As the PC does not have ACPI I've exhausted all the options suggested by the Rockwell KB articles.

Just noticed that V2.31 is now available so I'll give that a shot.

Thanks anyway.
Due to the SLC505's 16 connections limit on ethernet comms, we are unable to attach further PC's via ethernet as this currently has 14 read/write connections to other SLCs and I/O servers.

One of the uses of these PC's is for local emergency control if the I/O servers fail and so cannot be used as clients off the servers. Hence the need for serial comms.

I've read about power management problems on win2k and I'm in the process of going through all the settings to track down anything along these lines. I really like the way MS have subtly moved all the useful config programs from their location under WinNT....
There is a patch download you should install from Rockwell Softwares' web site, if you are running Win2k and are trying to run RSLinx PIC. Hope this might help.
Still no joy with 2.31 either.

Rockwell just announced a firmware upgrade for the SLC5/05 which allows 24 ethernet connections so after all that, it looks like we'll be reverting back to good ol' ethernet.

Thanks anyway everyone.