RSLogix500 Error


Thread Starter

Dino Sartor

Tried to upload a program out of a SLC500 (1747-L20A) and after the upload was done this is the error I received:

Upload Failed
Decompiler -> Unknown Error

Has anyone seen this before? Would like to know the cause and how to correct if possible.

Any help would be greatly appreciated.

The upload worked it just failed when the program in the processor was decompiled to try to get the ladder code. This is caused by a compiler/decompiler mismatch. What did you use to download the program? The same version of RSlogix? Did you use a handheld programmer to change the program? There were some problems with the decompiler that AB makes that were corrected and might solve your problem if you get the update.
The PLC is in a small packaging machine. This is the first time I've had to go into the program, we have never connected to it since it was delivered to us.

Bob Peterson

Usually this means they wrote the program in a version that is not compatible with your software, generally this means your software is an earlier version than what they wrote it in. Try upgrading to the latest version of RSLogix.

Or try AB tech support.