s5 connection/ setup headache


Thread Starter


Please can anyone help solve this headache of a problem

I am still trying to go online with my S5 and PC.

I am connecting to the com 1 port (9 pin- male) of my PC, with a 9 -25 female-female through connector. This is then connected to a siemens convertor pc/232 6es5-734-1bd20 (25 male - to CPU connector.

In s5 I have just selected the com 1 port and tried to change from offline to online which results in an error message saying PLC TIMEOUT,
or ascii ? port not ready. Is this a software setup error or hardware, I have also tried selecting com ports 1-4 but with no luck

Any ideas would be welcome!!


Vincent Bonesire

wich version of Step5 have you?

If you are working on Windows 95 or 98 check first if your com 1 is still selected in your PC's setup.I had this problem after upgrading my
Step5 in version 7.0. Before I had step5v6.85
I cannot find the file s5encomm.exe anywhere in the siemens directories. I have a file s5com but i think this is totally different to what
you are talking about. Please could you explain where to find this file and how to use it!

Thanks! mm

Zan Von Flue

I would also check the 25/9 pole adaptor.
It could be either pin 2/3 have to exchanged or not all pins are correctly connected. Easy would be a Comm.Quick tester. A better one has
swithes and Leds to check and configure, if necessary, the connection.

I had a similar problem when running S5 v7.14 on my desktop. A very old 3.2, pure CPM code with DOS/CPM emulator, worked with no problems, while
v7.14 did not.

Try downloading the S5ENCOMM.EXE patch from Siemens web site "http://www4.ad.siemens.de":http://www4.ad.siemens.de , it fixes a problem related to the RS232 voltage levels (affects both notebooks and desktops).

I would also update Step5 v7.0 to the latest version, check for upgrades at the above web address.

Luca Gallina