SattCon PLC


Thread Starter


We have a SattCon PLC. It looks like a single circuit board with a LCD display and membrane keypad that connects via a ribbon cable to a few I/O modules. I cannot see a model or part number on the unit so not sure which one exactly it is. The I/O modules are SD32D and XACV-B. An output has gone bad on the PLC and we need to readdress it.

So I found DOX10 (v 2.1-1) online and have tried going online to the PLC with it but have not been successful. I am not sure what all steps are necessary to go online. I created a new project and selected the PLC type as 05 and tried each of the different ones under that family. Then I tried a receive program from PLC. With some of the models, it immediately says either unknown PLC type connected or that the connected PLC type does not match what is configured in the project.

The only 2 where it attempts to try and get the program are SC05-45 and SC05-45EREG. I am using 9600 baud for the connection. Other baud rates do not seem to work at all. With these settings, it starts receiving and the byte count goes up but eventually it either fails with a timeout error message or a received data invalid message usually after it gets to an address that varies but usually in the 8AF6 to B856 range. I am not sure if there is a problem with the DOX10 installation as one of the disks pertaining to Sattcon35 was missing or bad.

Under the project settings page where I select the PLC type, for library it says 115 and so I am not sure if that is part of the problem and if so how to correct it. Under the C:\DOX10\Library folder I see library files called LIB_115.VE? as well as LIB_X5.VE? and manually entering LIB_X5 does not work.

I have not edited config.sys or autoexec.bat and am not sure if missing some entries there could be causing this problem.

I have tried this from within XP SP3. Also from within windows 95 by booting up a computer using a USB boot disk running windows 95. I have also tried from within a Virtual PC session running Windows 98. In all 3 cases, the computer has had a native onboard serial port and so I am not using a USB to serial adapter. However it is a relatively new and hence fast machine (3 years old) and so am not sure if CPU speed is perhaps a problem.

At times after the receive fails, I cannot connect and try again at all till I power cycle the PLC. When it fails the message I get is error while starting the PLC communication.

The cable pinout on the PC side is for a DB9F: pins 2,3,5 are coming from the PLC while pins 1,4,6,8 are all jumpered together.

Any help in figuring out how to get online to receive the program from the PLC and also to change an output address in the PLC would be greatly appreciated.


Patrick Beckett

It sounds like you have tried most things.

Did your installation of dox10 change the config.sys? There is a specific .sys file added to aid comms.

It may be that it was not programmed in dox10 at all. I have the impression that if programmed in dox5 it has to stay in dox5.

I should make you aware that these units are very near the end of all support from ABB. They will be declared unserviceable in three years, so plan your replacement now.
Yes dox10 install added
files = 20
buffers = 20
device = ansi.sys

However it still dies in the middle of receiving program with a received data invalid message. At times it dies right away while at times it goes for a bit before it dies. Playing with different timeout settings does not help. I realize these units are well past their use by date which is also part of why we are trying to retrieve the program from it.