Serial Communication with Gardner Denver ES+ Controller

G

Thread Starter

gallo27

Hey guys,

So I have a Gardner Denver Air Compressor (Electra Saver II) that has an AutoSentry ES+ Controller Version 2.12. I'm trying to communicate with it so that I can extract Maintenance and Operating Data and send it to our remote monitoring system.

Here is the communication protocol for the ES+ Controller from the Manufacturer.

-The ES+ Controller has an RS-232 port DB9 Female connector.
-The Port is DCE mode.
-Pin 5 is common
-RD data output is on pin 2
-TX data input is on pin 3
-CTS output is on pin 8
-All other pins are no connection
-Baud is 9600, data bits is 7, stop bit is 1, no parity, half duplex.

All data communications are initiated externally by requests for data. All requests are four character, of the form "<stx>xx<etx>".
-<stx> is ascii 2
-xx are identical text characters ("BB" is for maintenance data, "mm" is for operating mode, and "oo" is for operating data).
-<etx> is ascii 3

The final plan is to connect a serial cable to an Allen Bradley PLC and collect the data serially and then send it out through Ethernet IP protocol to our DCS system. But for now, I'm just trying to test the connection and receive the information from the ES+ controller to see how the string of characters look like so that I can write my ladder logic accordingly.

I am using Windows Hyperterminal to send my requests for data but so far I haven't had any success receiving anything back from the controller.

I am using a Straight through cable since I'm connecting a DTE device to a DCE device. My parameters on Hyperterminal are the same as the controller: Baud 9600, data bits: 7, Stop Bit: 1, no parity, and Flow Control: None.

I have tried sending different forms of ASCII characters, such as
- 2BB3
- 02424203
- 02BB03
- Etc,.....

I'm thinking I have to jumper pins 7 and 8, and also jumper pins 4 and 6 on my connectors but I'm not sure. Has anyone successfully done this before?

Please Help.
Thanks.

 
I've tried Cntrl+B to enter STX and Cntrl+C to enter ETX, but the controller doesn't respond with anything. Hyperterminal shows a "happyface" picture for Cntrl+B and a "heart" picture for Cntrl+C. Is this right? Am I doing something wrong? I'm new to this ASCII stuff.
 
Having the same issue with a Gardner Denver ES+ 200EAU1173. Tried RS232 on the DB9 port and RS485 on RJ11 port with a Keyspan USA-19H USB adapter without success. Using Kepware U-CON driver at the moment, but open to suggestions.

What am I missing???
 
Top