Servo valve won’t control mid range

Having an issue with the operation of a Moog valve not operating in the mid range. I’ve trawled through this forum and online but haven’t managed to find the answer to this specific question.

Over -20 to 20 mA it requires almost full scale before it will drive the actuator, and will only drive it fully open or closed. We have no control at any other point. The servo valve has been replaced 3 times, applying a mA source directly at the Moog to rule out the SFC/Positioner or earth faults in the cable and it remains the same.

The actuator responds rapidly once it sees +\-17mA or so, and remains stable when not being tested and there doesn’t look to be any contaminants/blockages in the reservoir.

Voltages, resistances etc. all correlate to a known working set up which is the same.

It's a good question. Do you have another servo location that you could try the servos on ? It's a long shot but could there be anything wrong in the hydraulics? When did this happen, did it work before, any system changes made?
Er, ..., Um, ..., This appears to be a steam turbine application, and I'm not really familiar with some of the older STs which use the Woodward SFC positioner in conjunction with a Moog servo-valve.

But, I have to ask: Have you changed the Woodward SFC positioner??? Moog servo-valves are the subject of many false narratives and many false descriptions. They are actually pretty simple devices which convert a current signal (ma) into a hydraulic flow-rate which is applied to an actuator (or in this case, apparently, a positioner which controls an actuator moving a valve).

If you've replaced the servo-valve and you are CERTAIN that the hydraulic fluid is clean but you haven't replaced the SFC positioner, that would seem to be the next logical step.

And, as glenmorangie asked: What has changed? Did this just start happening after some kind of outage (planned or otherwise)? Has the wiring been disturbed? Has the SFC positioner and/or the hydraulic actuator been disturbed (repaired/refurbished/replaced)?

Are you using new or refurbished servo-valves?

How many coils are in the Moog servo-valves (one; two; three)?

If there are multiple coils, have you tried putting out current to each coil individually to see what happens? (In other words, if there are multiple coils are you certain the polarity of the servo current(s) being applied to each coil are correct for the desired action?)

The intent of the questions IS NOT to make you have to do any extra work to answer them (though answers would be VERY helpful!!). The intent is to get you thinking about the different possibilities which might cause such a problem (you did ask...).

Hope this helps! Answers would be good--if you want more help with your problem.

A good description of the application would also be very helpful. Personally, I'm only familiar with bi-polar Moog servo-valves, which have relatively zero hydraulic flow when the reference to the valve is at 0 mA, and full flow at the maximum positive and negative reference currents.

And a good description of when the problem appeared would also be very helpful.
I agree with all of the above about the Servo's..Make sure the P/N's are correct. CSA, I ran in to this problem on a Steam Turbine. The Control Valve would hang up and take way more Servo current to try to pop it open. It turned out to be 2 things, First one is the Turbine Control Valve had bluing issues. Due mostly to not doing turbine Valve test. 2nd was Turbine Hydraulic cylinder #2 was contaminated with water and other particulate. GE Turbine with actuators mounted vertical on the bottom of the Valve Fulcrum InstL says he can drive it with a Transmation or similar device but it still takes 17ma. They can also find the Test port on the side of the cylinder and put a gage on it to see if the Pressure is getting there or not(Leak). I hope InstL follows up with a response. Good Day to all, Bob

Yes; it happens FAR TOO OFTEN that simply because servos look physically the same but have slightly different P/Ns (one character difference, or maybe two) that people believe they ARE the same. And, that's just NOT true for Moog servo-valves.

When I see that it takes "excessive" current to make a move usually resulting in overshoot of the intended position it's almost always a problem with a servo-valve that is contaminated from the hydraulic fluid being unclean OR some kind of mechanical binding in the actuator and/or device (valve, in this case).

It appears pretty certain this post is about a steam turbine (I've NEVER seen an SFC positioner used on a GE-design heavy duty gas turbine--but, admittedly, I've not seen EVERY GE-design gas turbine (just a lot of them)). And, from what I'm hearing these days, MANY (TOO MANY) sites are not performing the periodic valve tests they should be performing. MANY sites (TOO MANY) are not doing regular maintenance on steam turbine valves (stop valves; control valves; bypass valves; etc.)--which for steam turbines can be very, very bad. (There was site recently that hadn't done stop valve testing for several years, and when the unit needed to trip the stop valve did not close and at least one of the control valves did not close, either--due to silica build-up on the valve stems). The turbine and generator were destroyed in an overspeed event. It was a miracle that no one in the plant died, because the generator rotor rolled through the plant after it exited the generator casing....

Anyway, thanks for your input! Looks like the original poster has resolved his issue and doesn't feel the need to post with the findings/resolution. It is a free forum, after all.