SLC/504 to Laptop communication problem

  • Thread starter Froilan del castillo
  • Start date

Thread Starter

Froilan del castillo

Hello there!

Im seeking help on SLC/504 communication. Im new to this thing. I got a laptop ("Fujitsu" "Lifebook 780TX) turned over to me recently on Windows 98 preloaded with RSLogix500 and RSLinx Lite. I need to establish communication with AB's SLC/504 using my fabricated RS-232 DB9 cable (same as 1747-CP3 for DTAM Micro) so i can have copy on its program. I've read about Mullenix thomas case and Brad Hite's reply and write up on RSLinx and tried those. On auto configuration phase of RSlinx, this error message always come up "Unable to open com port for configuration setting". What does it mean? Im configuring on RSLinx driver RS232DF1 devices on com1 port on channel 0 device SLC-CHO/micropanel view. On that i cant proceed any further, Thru control panel tried to check com1 port if being allocated by another sofware, found one (1) in modem, remove such but on test again still got the same error message. I dont know what to do now! Looking for help to any out there! Thanks so much.
suggest that you post your question at you'll get much quicker response there... all posts to the forum that we're currently on must go through the moderators... that can take a day or two for each post... posting on is realtime...

some suggestions for your problem: make sure that DF1 is the ONLY driver in RSLinx... make sure that RSLinx is not running as a "service"... make sure that you have administrator privileges to control the serial port...

good luck.
You have one of two possible problems.

1. You are not choosing the right com port. Go into Control Panel and Device Manager and look under com ports. Se what com ports are numbered there.

2. You have another application that has control of the com port already. If this is the case, you need to determine what applications are running in the background and shut them down.

Give me a call and I can walk you through it over the phone.

The channel 0 communication setting could be set to DH485. In that case, you will need to use the PIC driver in RSLinx.
make sure that the port is not taken by another application. Stop RSLinx as a service and run it normaly from the start menu. You may have problems with your serial port, so try it with another PC using Xtalk or Hyperterminal

good luck,

Gerald Beaudoin

I had a Fujitsu Lifebook for a couple of years and had all sorts of problems regarding assignment of ports. Was never able to totally resolve the problem....In my case the Rockwell stuff worked ok but I could not get any other software to communicate through the com ports. Sounds similar only reversed. No technical help from anyone... just finger pointing. Finally dumped the notebook for a newer one and will forever avoid Fujitsu.
FYI you can also use a 9 pin serial cable with null modem adapter rather than fabricating your own cable.

So where are you with your com port in the control panel. does it show up as comm1 communications port? How is a modem showing up under comm ports?
something is using the com port, it could be a modem or fax software.

Try closing all services that you dont need.

Try creating a new user and log in as this user. Made all services start manually.