Start Command not going through to Gas Turbine


Thread Starter


In an attempt to start a GE MS50001 turbine, the start command is not going through to the control system when it is clicked from the HMI. instead of changing from Ready to start to starting before cranking, then firing etc, it will remain on ready to start. I have restarted the TCP (it is a MARK V Control system). so I have restarted all the R, S, T AND C core, restarted the HMI, and even the project twice but the unit is still not starting.

Please help
MY email is [email protected] for any direct contact ...


Have you used VIEW2 to see if L1START_CPB is changing from a logic "0" to a logic "1" when you click on the START target?

If it was working, what changed in the time between it was working and now? Has someone been making changes to one or more of the .ASG files and recompiling using MK5MAKE.BAT, then downloading and rebooting? If so, it's possible that somehow L1START_CPB was inadvertently changed.

You should also be monitoring L1START to see if it goes to logic "1" when you initiate a START.

Or, has someone been editing the .CIM display and inadvertently changed the START target's configuration?

When a START is issued when a "Ready to Start" is active there are several things that must happen before L4 will pick up, the most important being that there must be L.O. pressure.

Use the Dynamic Rung Display to monitor the L4S rung and any other logics that are required to make L4S go to a logic "1". Sometimes there must also be Cooling Water pressure before L4S will go to logic "1"--but it is entirely possible that the START is getting to the Mark V (L1START goes to logic "1") but one of the permissives that are required to complete the START process (to set L4 to logic "1") is not occurring to allow the sequence to continue. (It's always been stoopid that GE didn't alarm when one of the permissives for L4 didn't get set in some period of time when a START is "in progress".)

It's either something like this--or something has changed.

If the unit has FAST LOAD START you could try issuing a FAST LOAD START and if the unit actually starts then it's something amiss with the START command. (When the generator breaker closes (synchronizes) during a Fast Load Start it will load very fast--unless you give a RAISE or LOWER very quickly to abort the fast loading.)

If the unit doesn't start when you initiate a FAST LOAD START then it's most likely some permissive that isn't being satisfied.

Write back to let us know what you find.

Have you tried using the <BOI> to initiate a start? (There are instructions in the Mark V Users Guide, GEH-5979.)

Also, there is probably a Demand Display with a START target on it.

If the Mark V still won't "start" with either of those two methods then it's likely some permissive to allow L4 to be picked up is not being satisfied.

Please write back with the results of your efforts.
Thank you very much for your response, I will do all of these things and get back to you on the outcomes

Am so grateful