Twido PLC not accepting program download


Thread Starter


Dear Friends,

we are commissioning a machine having TWIDO PLC (TWDLMDA20DRT + TWDDRA16RT). The machine was lying idle for a year before commissioning. When we powered up the machine we have observed ERR LED in PLC flashing RED. After communication with PLC we found that the application program is not there. We contacted the OEM & he sent us the program. When we try to download the program the PLC is giving checksum error & download is aborted every time. I am unable to understand what is checksum error & what will be the possible cause of it. One more observation is the PLC is not showing any mode, i.e. it is not in RUN/STOP mode. The manual says it is in HALT but there is no way described to put it in RUN or STOP.

Kindly suggest a solution.


PLC Programmer

Which cable you are using for programming?

If it is not a ready-made cable please check the pin configuration of the cable.
Dear Sir,

I am using TSXPCX1031 cable. I tried to communicate with the PLC & download the user application sent by my OEM using TWIDOSOFT V3.5 but PLC is not accepting. I get message "Local application checksum & controller checksum are not matching". Is there any way or any specific set of software + firmware version I can use to make this PLC accept the user application? Or I will have to search the exact set used by the person who has first programmed it? I have the PDF of the program & if the above trick works I can rewrite the program in the TWIDOSOFT version I am using.

PLC Programmer

TWDLMDA20DRT SV3.5 TWIDO20r_V0350P0X.tfw

Please try to update the firmware.

The latest firmware is is available at schneider site...
I have the same problem!! Could you solve the problem? If so, please tell me how you solved it.

Thank you so much.