Win2KS auto log on

  • Thread starter Donald Pittendrigh
  • Start date
D

Thread Starter

Donald Pittendrigh

Hi All

Can someone please put me out of my misery and tell me where in Win2k server the password logon gets set to a default user name and password so the machine can automatically boot and run up when the power is switched on.

I know it is possible as I have done it before, but cannot remember where, there is no users icon in the control panel as in Win2kPro and in the computer manager under users I do not find a possibility to set the default logon.

Thanks
Donald Pittendrigh
 
J

Jacki Wenzlick

Donald,

Microsoft KB article Q234562 (How to set up Windows 2000 for Auto Login) says this is only available for Win2K Pro and is not an option on Win2K server or Advanced server. But maybe there is some super-secret registery way around this.

good luck,

Jacki
 
You will find all of the appropriate settings here.
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

You may need to add DefaultUserName, DefaultPassword and AutoAdminLogon. They are all REG_SZ data types.
 
G

gino mettepenningen

To enable automatically logon, do the following:

(click on start-Run and type) Start Regedt32.exe,and then locate the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon

Using your account name and password, double-click the DefaultUserName entry, type your user name, and then click OK.

Double-click the DefaultPassword entry, type your passworde, and then click OK.

NOTE:if the DefaultPassword value does not exist, follow these steps:

Click Add Value on the Edit menu

In the Value Name box, type Defaultpassword, and then click REG_SZ for the Data Type

Type your password in the String box, and then save your changes.

Also, if no DefaultPassword string is specified, Windows automatically changes the value of the AutoAdminlogon key from 1 (true) to 0 (false), which disables the AutoAdminlogon feature.

Click Add Value on the Edit menu, enter AutoAdminLogon in the Value Name box, and then click REG_SZ for the Data Type.

Type 1 in the String box, and then save your changes.

Quit Regedt32.

Click Start, click Shutdown, and then click OK to turn off your computer.

Resart your computer and Windows.you are now able to log on aytomatically.

It's werk, i have done this a few time's for a visualisation.

Goed luke, gino_me[email protected]
 
B

Bob Peterson

Its a registry entry. I forget where it is but MS has a knowledge base article on it.

Bob Peterson
 
M

Michel A. Levesque, eng.

You have two good explanations on how to go about setting up the AutoLogon in the registry. Don't forget to add the DefaultDomain key also if you want to login to a domain.
 
I have been doing a lot of this lately... if this doesn't help, let me know.

1. Reboot the PC
2. Create ntautologonuser Start>Settings>Control Panel>Users
and Passwords
Add ntautologon user
Uncheck User must change password at next logon
Check User cannot change password
Check Password never expires

3. Configure ntautologonuser Uncheck startup box
Start>Settings>Taskbar & Start Menu?
Check first four checkboxes. Uncheck fifth checkbox.

4. Configure Auto Logon
Run regedt32
Select HKEY_LOCAL_MACHINE
Open SOFTWARE\Microsoft\Windows
NT\CurrentVersion
Click WinLogon
Set AutoAdminLogon 1
Set DefaultDomainName to Computer Name
Set DefaultUserName to ntautologonuser

Paul T
 
G

Gabriele Corrieri

Hi Donald,
you can set auto logon without password in Control Panel / Users and password, by unset the checkbox 'For using ...'
Now the system will logon without requesting username and password, but it will logon as Administrator, take carefully that in this state the user (or any application that runs in this session) could be destroy the system.

Hope this helps you.

Gabriele Corrieri
 
W

Wayne Curnuck

You can always simply get the TweakUI as supplied by MS. It does this as well as packaging a few other 'tools' and keeps things easy to use with a
simple interface.

Wayne Curnuck
 
D

Donald Pittendrigh

Hi All

This problem is solved, it seems there is no simple point and click place to make the setting, I was referred to the correct registry settings by a list member, I looked it up in my registry manual and was resolved to edit the registry and set things up the way I wanted, when another list member sent me a neat little utility which does the setting for you.

Thanks to all who responded to my plea for sanity preservation.

Regards
Donald Pittendrigh
 
D

Donald Pittendrigh

Hi All

Mmmmmm..... I believe in the original post I did say that the operating system was 2000 Server, or Win2kS as shown in the subject line. This of course does not have Users etc. as an icon in the control panel, but rather it is found under computer manager, which does not provide the opportunity to make the settings you have so kindly described.

For general info, if 2000 server is installed it does provide the option to set a default user, when it asks the question,

"should windows always assume the following user has logged onto this PC"

Or allows you to set an admin password. It seems this is the last time you get the option to make this setting in plain English, and should you forgo the privilege, you end up with the problem I have described. Fortunately some kind lister,
has sent me a very useful app. That makes the setting for you and it was extracted from the NT resource kit.

Nice day
Donald Pittendrigh

>I have been doing a lot of this lately... if this doesn't help, let me know.
>
>1. Reboot the PC
>2. Create ntautologonuser
> Start>Settings>Control Panel>Users and Passwords
> Add ntautologon user
> Uncheck User must change password at next
> logon
 
A

Armando ABRAHAM

Open the windows registry (regedit.exe at command prompt) and go to
KEY_LOCAL_MACHINE\SOFTWARE\MICROSOFT\WINDOWSNT\CURRENTVERSION\WINLOGON.
There, you'll find all that you need to do the autologon
(defalutDomainName,DefaultUserName, etc).
Best Regards.

Armando Abraham
 
Easiest way is: Control Panel> Passwords & Users

UN-check the box that tells the computer to require a login. If it is already unchecked, check it (trust me). OK out if you checked it. Return to it and UN-check it. When you hit OK this time, the computer will prompt you for a default user and password to be logged on...

David
 
David, you're right, this is what I tell people to do in Win2K and Win2KS... It seems MicroSoft bungled the interface for this option.

Kelly
 
D

Donald Pittendrigh

Hi All

I raised this issue within the last year on this forum, and I still can't find the users and passwords icon in the control panel in WIN2KS which according to the topic heading, is what this query is about.

A search of the archives will show who did respond with the right answer, I cannot remember who it was.

Regards
Donald Pittendrigh

>> Easiest way is: Control Panel> Passwords & Users
>
> UN-check the box that tells the computer to require a login. If it is
already unchecked, check it (trust me). OK out if you checked it. Return to
it and UN-check it. When you hit OK this time, the computer will prompt you
for a default user and password to be logged on... <
 
P

Paul Watts (aka Bodwad)

In regedit

Goto Run:
Type Regedit and hit enter

move through this path:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Check The Key 'DefaultUsername' is correct to your username

Check (or create a text key) called 'DefaultPassword' again enter correct value

Add a new key (String Again) and call it 'AutoAdminLogon'
Set That Key to '1'

Restart and Voila =P
 
Top