Today is...
Monday, April 22, 2019
Welcome to, the global online
community of automation professionals.
Featured Video...
Featured Video
EtherCAT with CTC’s master lets your multivendor network play well together...
Our Advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive
Indusoft AS511 driver
Has anyone configured Indusoft's AS511 driver?

Has anyone configured Indusoft's AS511 driver? I should connect an old S5 PLC to Indusoft based HMI. After system rebooting, when I first click Run, receive: "Error initializing driver AS511 11.04: Invalid serial port". Second:"Port allredy in use".
Nbr of port is correct, I checked up it many times.

Any suggestion?

By Andre Bastos on 6 October, 2006 - 7:51 pm

You can workaround this issue following the steps below:
- Stop your InduSoft Web Studio runtime, if it is running
- On your application, go to the COMM tab
- find the Drivers->AS511 folder
- right-click on the AS511 and select "Settings"
- in the "Order Of Words" field, please type "0"

It should solve the problem.
We are about to release a newer driver version that takes care of this issue, and should be able to download from shortly.
Should you have any question, please let me know.

By Thomas Richards on 31 May, 2018 - 6:23 pm

I've been having a similar driver issue when trying to connect my Velocio PLC to my PC's InTouch Machine Edition. I've been using the MODBUS Protocol RTU abbreviated MODBU. Whenever I try to run the application and retrieve a tag from its MODBUS address, I get the same "Error Initializing MODBU Driver: Invalid Serial Port." I've checked to make sure that the serial ports match and even tried changing them to no avail. When I sent my application to a different computer, it worked without an issue. Any ideas?

Thanks so much