Today is...
Wednesday, August 21, 2019
Welcome to Control.com, the global online
community of automation professionals.
Featured Video...
Featured Video
A demonstration of EtherCAT control of linear motors using the CTC EtherCAT master.
Our Advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive
Clearing Faults on Allen-Bradley MicroLogix 1100
Please whats the procedure for clearing faults on 1100 allen-bradley Micrologix PLC.

Our control valve suddenly stopped throttling. Troubleshooting revealed that the transducer is not receiving a control signal of 4-20mA from the allen bradley MicroLogix 1100 PLC. What could be the possible cause? and whats the procedure for clearing faults on 1100 allen bradley Micrologix PLC.

My e-mail: thanniglobal [at] yahoo.com

By bob peterson on 4 November, 2010 - 9:25 am

It could be all kinds of things.

Is the PLC in run mode? Off the top of my head I don't recall if the 1100 has a little switch for this. I think it may.

If the PLC has faulted, you can clear the fault with the programming software (RSLogix 500). Sometimes people set the PLC up so that you can cycle power and reset the fault, and return to run mode (it's an option that has to be selected so it may or may not work on your PLC).

If it has faulted it could be something that can't be cleared, like an I/O module that faulted. The only way I know of to tell what the fault is would be is to look in the status file in the data table. It will give you an error code that tells you what faulted, and that should lead you very quickly to fixing whatever went wrong.

Presumably the control signal to the valve is being calculated in some way by the PLC. Perhaps a PID loop inside the PLC. It might be that for some reason the loop went into manual mode and set the output to 0%. Perhaps because it lost the feedback signal. That's not an uncoomon way of programmers handling that kind of fault.

The best way to debug these kinds of problems with a PLC involves using the PLC programming software tools. That's just the way it is with PLCs.

It could be a defective analog output point. It might even be a loose wire somewhere. But tracking it down in an expeditious way almost always involves using the PLC programming software for that PLC.

--
Bob