Today is...
Sunday, August 25, 2019
Welcome to Control.com, the global online
community of automation professionals.
Featured Video...
Featured Video
EtherCAT with CTC’s master lets your multivendor network play well together...
Our Advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive
Control.com now encrypted
Control.com has been converted to SSL/TLS
1 out of 1 members thought this post was helpful...

Hi all,

A quick note to let you know that we've converted Control.com to be served as an encrypted site. You shouldn't notice any difference -- any access to http://control.com will automatically get converted to https://control.com, as will any of our sub-communities.

Please let us know if you run into any problems. We've done some regression testing, but there could be some browser-specific issues we weren't able to catch. For example, it's quite possible that anyone using Windows XP with an old version of Internet Explorer will have problems, for which I might suggest <ahem> Firefox or Chrome.

Ken Crater
ken@control.com

Thank you, Mr. Ken!!!

I think it might have broken the site search engine.

The search results for RS-485, Modbus and shielded each returned zero hits.

>The search results for RS-485, Modbus and shielded each
>returned zero hits.

Thanks for the report, David. I checked it out, though, and can't replicate it here for Modbus (returns thousands of results, as might be expected) or shielded.

The RS-485 search may be a special case. The search tool we use interprets the - as a minus sign, meaning that you're looking for items not including 485, and the remaining term RS is too short to search on. However, rs485 (without the hyphen) does return results.

Maybe there's some caching happening at your browser that is interfering with the other results? I'll continue to try to replicate it here on other platforms, though.

Ken

Ken,

Firefox now finds normal words like modbus, cable, wire (although it balked this morning).

But the engine still has problems with 3 letter acronyms (maybe it always did?)
It can't find 485 or RTU or rtu or CPU or TIA or UDC or CDA or I/O or PLC or P/S

It finds 4 character non-words like fc03, fc04 without a problem.

>But the engine still has problems with 3 letter acronyms
>(maybe it always did?)
...
>It finds 4 character non-words like fc03, fc04 without a
>problem.

Yes, this hasn't changed. The search tool we use has a minimum word length (set to 4 characters), mainly to keep database indices to a manageable size. Unfortunate, but we need to live with it.

However, note that you can do a Google search on, for example:
site:control.com RTU

This will return only results from Control.com without a lot of irrelevant references like Rajasthan Technical University.

Ken

By Dave Ferguson on 27 June, 2018 - 2:58 pm

Tried to use phone yesterday and it doesn’t like your security certificate.....says it is expired....

Safari browser on iPhone.

Dave Ferguson
Control Systems Engineer

Sent from my iPhone

>Safari browser on iPhone.

Thanks for the report, Dave. I can't replicate the issue here - I have an iPhone 6, and I've tried FireFox, Safari and Edge(!!) and all seem to accept the certificate. Since the certificate was issued just a couple of days ago, there shouldn't be an issue with it, but it may be another instance of caching of some content that's causing a temporary problem during transition.

Please let us know if it's a persistent problem, though, and thanks for bearing with us through the cutover period.

Ken

By Dave Ferguson on 28 June, 2018 - 8:57 am

Here are the screen shots that I get now when I try to click on a thread.......

Just trying to help report something new since the change....

Who knows maybe I have something wrong but it used to work.....who could possible keep up with all this "fun" stuff :-)

IPhone X and Safari

https://drive.google.com/file/d/1eZqmObKTtmBTn7AaYgh2f7ebdQUdz0r6/view

Dave Ferguson
Control Systems Engineer