Today is...
Friday, August 23, 2019
Welcome to Control.com, the global online
community of automation professionals.
Featured Video...
Featured Video
Wiring and programming your servos and I/O just got a lot easier...
Our Advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive
PGT10 / GE10B1 - Flashback During Acceleration (Mark VIe control)
PGT10 - GE10B1, Speedtronic Mark VIe (old SUVIMAC II removed in 2014). Since the Hot Path Inspection, the machine trip on Flashback at 5200 rpm.

Machine: PGT10 - GE10B1
Control system: Speedtronic Mark VIe (old SUVIMAC II removed in 2014)

Since the Hot Path Inspection the machine trip on Flashback at 5200 rpm.

Machine was running fine on base load during normal operation.
In April, the unit was stopped to perform Hot Path Inspection.

Combustion chamber had been 1st replaced. No problem noticed.

At restart, in CRANK mode, calibration has been done for main position regulators (for IGV, SRV, GCV, GTV and ATV). No problem noticed.

Then unit was set on FIRE mode, no problem noticed.

Then unit was set to AUTO mode and started its acceleration. When reaching 5000 rpm, the "nose flashback temp" increased quickly to Trip value and TRIPPED the machine.

Second test, after a long CRANK to vent the combustion chamber (1h), the unit is set directly to AUTO mode. Same TRIP (flashback) at around 5000 rpm.

Then we have changed both "nose flashback temp" (#5 and #6).
Third test, same TRIP (flashback).

Then we have reopened the combustion chamber. We checked the different parts without seeing any defect. We have replaced the "New" combustion chamber by the "Old" combustion chamber.

We have also proceeded to a compressor wash.

We have also replaced the GTV (tertiary gas valve).

After a long crank to vent the machine, we made a new restart.
Same TRIP for Flashback on "Nose Flashback temp".


Next week we will try again to start and check on the software side (Mark VIe):
- we may control the tertiary gas flow proportion
- we may check the instruments on the gas line and on the air "line"
- we may modify the constants during acceleration (acceleration rate, lambda set, tertiary gas demand).

For information, before last season of production (october 2017), we already got 2 flashback TRIP during acceleration. But the unit had started and ran well during the season.

Does anyone have an idea of what could lead to our problem?

Thanks in advance for your ideas.

Regards