Today is...
Monday, July 22, 2019
Welcome to Control.com, the global online
community of automation professionals.
Featured Video...
Featured Video
EtherCAT with CTC’s master lets your multivendor network play well together...
Our Advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive
Solaredge Gateway
Solaredge Gateway not waking automatically

My first post, please be gentle.

I connected my Solaredge inverter via RJ45 to my router and enabled Modbus communication on the inverter.

On my PC using Homeseer 3 software and a Modbus plugin I selected the IP address of the inverter and I am able to read various pieces of data. The connection stays awake as long as I poll more often than every two minutes, so for now I poll every 90 seconds.

I set polling to start at sunrise and stop at sunset. Shortly after sunset the inverter goes into night mode and all is well.

In the morning I enable polling but the software will not connect to the inverter until I press a radio button that says "Test". As soon as that happens, polling begins and continues until sundown.

At this point I believe I need a script that will press the "Test" button to get things going, but I have no idea if this is even possible. Or for that matter what is keeping communication from beginning.

Can anyone help?