Today is...
Wednesday, November 21, 2018
Welcome to Control.com, the global online
community of automation professionals.
Featured Video...
Featured Video
Wiring and programming your servos and I/O just got a lot easier...
Our Advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive
Ex2100e Excitation System Startup issue
Frame 7Ea gas turbine simple cycle, excitation system issue

Hi,

Ex2100e system is giving intermittent problem in our GT GE-7ea. TCS is Mark-VIe.

Most of the time we found that the excitation system blocks the start-up of the turbine, and we need to reset the exciter multiple times. Sometime we need to hard reset of excitation panel supply CB to get rid of this issue. The local display unit of Ex2100e is hanging and touch panel is not responding despite its reset.

Can someone share the general troubleshooting guide on Ex2100e system? and shed a light on possible reasons for aforementioned problems?

Appreciate the feedback!
Thank you.

1 out of 1 members thought this post was helpful...

It'll take a little more detail to help any. Aside from the local operator interface problem, what specific permissives, alarms or behaviors are blocking startup?

On the operator interface, I could have told you anything about the prior generation EX2100's COI, but they have a new touchscreen and software now that is totally different.

My best guesses based on what you've described would be a Network switch or cabling issue, faulty power supply, or grounding.

Thanks for the reply. Issue is related to cabling, and upon available shutdown we have planned to replace the communication cable.