Today is...
Saturday, August 17, 2019
Welcome to, the global online
community of automation professionals.
Featured Video...
Featured Video
EtherCAT with CTC’s master lets your multivendor network play well together...
Our Advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive
Modbus TCP and Citect SCADA 6.10
Modbus TCP driver for Citect v6.10?


I have nearly finished my degree and then i came across this little problem. It seems that i cannot find a driver for Modbus TCP in Citect SCADA 6.10 when i run the driver wizard.

I have to integrate metering system with Carlo Gavazzis VMUC-EM. I have done all my testings on the version 7.20 which has industry standard protocol, and it has modbus tcp in it. Now i'd like to take what learned in practice and use them in this project which has the version 6.10.

So does anybody know that is there a specific driver in it which is under different name or manufacturer? Can i download drivers somewhere or can i transfer driver files from my Citect 7.20?

If you can help me with this; i would be very happy because this affects on my graduation...

Thank you for your answers already!

You should find MODNET to use Modbus TCP driver.
Maybe this link help you.

For download driver please check this link.

>For download driver please check this link.

Thank you very much. I downloaded few versions of those driver packs before they moved their site. I found the same i driver protocols that i have used.

Now i have a new problem... It seem that i get #COM when i setup my communication as in my test project. I have also checked if ports were open by using telnet in cmd; it seemed that there was not the problem.

Citect Scada kernel gives me error

"Error: Channel offline, cannot talk
Generic 000021 Driver 00000020 (0x00000014)"

I googled the error code but all i got was this:

Could this mean that PC hardware is just old or something. Actually the server pc is XP and over 10 years old.

1 out of 1 members thought this post was helpful...


I managed to get a solution for this. It seemed that the TCPIP driver was out of date, so i updated it. Now it works like a magic.