Today is...
Monday, October 21, 2019
Welcome to Control.com, the global online
community of automation professionals.
Featured Video...
Featured Video
A demonstration of EtherCAT control of linear motors using the CTC EtherCAT master.
Our Advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive
Unable to Install ToolboxST V04.07.06C on Laptop
Unable to install Toolbox ST V04.07.06C on laptop with Windows 8.1 Enterprise.

Hello,

I am unable to install Toolbox ST V04.07.06C on my laptop which has Windows 8.1 Enterprise. Getting the message "OS not recognised. Operating System ID=2, Product ID='. Cannot determine if installation on this machine is valid". I have a license USB dongle in place during the installation.

Hi,

For your information: this is not about the DONGLE (dongle is a hardware license to open the app after installation).

Instead you can see on your toolbox DVD package supported OS. If windows 8 is not supported by your version, I'm afraid to tell you that you cannot install it on that laptop.

Good luck.

2 out of 2 members thought this post was helpful...

Zasher,

Windows 8.1 is not a supported operating system for the Toolbox software. For this particular version I believe WinXP and Windows 7 are supported. I have also had success installing it on Server 2008R2. I use virtual machine software (VMware) for all my installations. You can install the software without the dongle, you just wont be able to use it without the dongle.

2 out of 2 members thought this post was helpful...

GE likes to support known good sets of software versions that have been tested together, and there was never a combination that included Windows 8.1. However, while ControlST never officially supported Windows 8/8.1 (it jumped from 7 right to 10 in ControlST 7.0), it actually does work on Windows 8.1. You'd be taking a risk since it isn't supported, there are possibly corner cases and odd behaviors you'll run into. Many of those are related to the fairly complex compatibility matrix between ControlST, CIMPLICITY, and various drivers and utilities that typically have to run together on an HMI. If you're only running ToolboxST the issues are less troublesome.

Some are Microsoft issues--in particular, watch out for the .NET framework 4.6 update, as it had a non-backward compatible change that broke most older versions of ControlST.

You can force ControlST to install by running the Setup program in windows 7 compatibility mode. You can do this by right-clicking the Setup.exe and selecting properties, the Compatibility tab, and set the Compatibility mode to Windows 7. I'd only do this if you're willing to put up with unsupported issues. :) I haven't done this in a while so there may be a step or two I'm forgetting.

1 out of 1 members thought this post was helpful...

Thanks. That worked very well. ToolboxST is now installed on the laptop.

0 out of 1 members thought this post was helpful...

Can install toolbox in widows 10? When i am installing am getting the same error as you got first?
have you installed the toolbox in windows 8?
or changed the OS?

By demigrog2 on 4 March, 2019 - 12:10 pm
1 out of 1 members thought this post was helpful...

While that same procedure will work to install old ToolboxST versions on Windows 10, it is almost impossible to avoid the .NET 4.6.2 update that breaks older versions of ToolboxST. Microsoft includes it out of the box on the latest Windows 10 builds and pushes it without asking on the older ones.

If you're in a position to upgrade, ToolboxST V04.07.12C fixed the compatibility issue. GE has issued CSB25346 on the problem.