Today is...
Friday, August 23, 2019
Welcome to Control.com, the global online
community of automation professionals.
Featured Video...
Featured Video
A tutorial introduction to programming using the QuickBuilder Programming Environment.
Our Advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive
Mark VIe Simulator Problem
Issue with starting my MARK VIe simulator

Hi everyone,

I have some issue with starting my MARK VIe simulator even if i try many times. I always get this message (ERROR C:\Documents and Settings\maint\Desktop\G1_TIL\programshutdown.pcode Not a pcode file
ERROR Pcode Serialize Failed.).

I included a photo for my problem.

Please could someone help me.
Thanks so much.
My email address is ateknasreddine@gmail.com

Moderator's Note: You cannot post photos or other attachments to Control.com. You need to post it on a site such as google docs.

1 out of 1 members thought this post was helpful...

I have had that issue on code for one of our plants, using Virtual controller ControlST version 4.07.03.01 build3 when trying to download from devices running ControlST same version. I started deleting tasks and found the block that was causing the problem, it was in the HAZ gas program area. Interestingly, a year or so later that plant bought a HAZ gas upgrade from GE and GE supplied new library blocks and the problem went away. I have never had the issue with the ControlST virtual controller version 5 or 6.

So, I am sure lots of things can cause the issue, but I would start deleting programs/tasks to see if it is a problem block somewhere in the logic you are downloading.

Also, as with everything GE, there are a number of things that the documentation is unclear on, you have to experiment to get the configuration right.

By demigrog2 on 3 July, 2019 - 10:45 am
1 out of 1 members thought this post was helpful...

Sounds like a mismatch between the version of the Virtual Mark VIe and the Mark VIe runtime version used in your controller configuration.

In a real Mark VIe, the runtime firmware (including block libraries) is downloaded to the controller, forcing it to match the configuration in ToolboxST. In a Virtual Mark VIe, the firmware download actually doesn't do anything; the block libraries are baked into the simulator. So, if you have a newer Mark VIe runtime configured, a block may be missing or have different pins in the older Virtual Mark VIe -- or vice versa. ToolboxST doesn't detect the problem and prevent the download.

What version of the Virtual Mark VIe are you running, and what is the Mark VIe Runtime version used by your device (see the property grid for the General tab)?

Hello again,

Thank you for you replies.

I included a link to the photo of my MARK VIe simulator problem
https://drive.google.com/file/d/0B7bLPH9otvObRnZTWW9makxWZXRRN21mWHdHUFh1N0NlZzkw/view?usp=sharing

Please help me demigrog2

By demigrog2 on 8 July, 2019 - 10:08 am

You need the version number from the virtual controller. It will tell you on the splash screen when it starts, or you can use About from the Help menu in the Mark VIe Virtual Controller window.

You also need the configured Mark VIe product version from your ToolboxST configuration. If you open G1 in ToolboxST, on the General tab, scroll down the property grid until you see the Product Version property (in the General category).

In general, the two versions should match, at least the first two numbers. Often it will still work if the two versions are close (changes to block libraries are infrequent). What versions do you have?