Today is...
Saturday, August 17, 2019
Welcome to Control.com, the global online
community of automation professionals.
Featured Video...
Featured Video
Wiring and programming your servos and I/O just got a lot easier...
Our Advertisers
Help keep our servers running...
Patronize our advertisers!
Visit our Post Archive
Endress and Hauser Promag 53 Network Failure
Trying to figure out why FITs lose network communication at times.
1 out of 1 members thought this post was helpful...

We are using E&H Promag 53 to measure flow. the system we are using is a Rockwell DCS. we have segregated the control cables from the power cables in our racking system and have grounded the shield in the RIO panels. The problem we are having is that at times the FITs just lose network and fail to communicate. the IP address at this point will not have changed as well as the subnet musk and gateway. we have found out that the fastest way to regain communication is to recycle the power on the transmitter. why it does this we are not sure. help

Using connected or unconnected messages? Can you open the webserver? What are the colours of the status lights when you lose connection? Are you using the add-on profile? What are the faults (if any)? Have you tried using Wireshark to inspect the packets?

Hi MrAnon,

I am not sure what connected and unconnected communication is, can you explain what that is. Sometime both LED are flashing green or both solid red. At times they are both off. Rarely, they are both solid green and no communication received. The local display does not show any errors at this point. We are using the Add-on profile. We have not used as yet, so we will try it the next time we have an error.

Hello Maclaughlin,

Can you please share following data to us :

- The "system architecture diagram" or "Ethernet network arrangement
diagram"

- RSLogix 5000 backup file that saved and uploaded when communication to Promag 53 is failed

- prinsscreen of HMI

- prinsreen of RSLogix 5000 failed message

so we will be able to analyze your problem. Current information is not enough for us to be helpful to you since we can't see the fail message from HMI and RSLogix 5000. We don't know how is your system arranged, we don't know how is your Promag 53 configured, and programmed on RSLogix 5000.

Basically, E+H Promag 53 is a Electromagnetic flowmeter, and we can
integrate this device into Rockwell controllogix thru EthernetIP network using AOP (Add on Profile), AOI (Add on instruction), FTview Process object, and EDS files that available to download from Rockwell and Endress+Hauser website.

Rockwell provide integration guidance for E+H Promag 53 as below, if you don't have I recommend you to learn this documents first:

http://docslide.us/documents/promass-83-flowmeter-via-ethernetip-to-the-plantpax-process-automation-system.html

Hope this help you
Ikhtiander

By Maclaughlin on 9 November, 2016 - 8:29 pm

Hi Ikhtiander,

we will try and post the requested details when the error happens again. Thanks for the link, I will go through it and see what I can find that I did not do.

Hi,

I have the same problem with a Promag 300 5H3B E + H. Installed the EDS downloaded from the E + H website.

My system is a controllogix L62 with a communication card 1756-ENBT. Add the device as it appears in the E + H manual, but it does not communicate with the PLC.

The Rslinx does not recognize it. I make a PING to the IP and if it communicates also via web I can communicate and configure.