Mark VIe Pack Does Not Communicate


Thread Starter


Hey all.

Recently a change was made to a PAIC pack to eliminate a persistent diagnostic alarm for a transmitter that has been removed. The change was downloaded to the controller, and after the download completed a slew of alarms and bad readings came in related to a different I/O pack. Upon investigation it seems a PSCA pack isn't communicating to either IONet. We are unsure if during the download to the PAIC, the wizard detected a difference to the PSCA and automatically checked those boxes for download but it seems likely given the results after the download. It was attempted to undo the changes and redownload, but that did not help. We then downloaded to the PSCA pack Baseload, Firmware and Parameters but that also did not help. We rebooted the pack (power off then on) and the controllers but that did not help. We have not made any changes to the application code and therefore that was not downloaded.

The errors we are getting is that we have no signals (all Modbus) from that Pack/Module. We are getting diagnostics on that pack (PSCA) for loss of communication to controller and "unhealthy IONet - Minor Signature mismatch". We are also getting status errors for the pack stating under health "BAD_SIG_MAJOR". Lastly when doing a compare we are seeing difference for the PSCA pack under the category "IONet Exchange Versions -> GeCss Config IO Distributed.IoNetExchangeVersion -> SigMajor" with the Toolbox version showing a "5" and the Controller version showing a "4".

Any help would be greatly appreciated. Thanks in advance.
Sounds like some sort of unintended change occurred to the PSCA configuration, and the controller and pack no longer match. It might not have even been an actual change, but some action that bumped the signature for the I/O pack's EGD exchange without changing anything. When this happens, you need to rebuild and download the controller as well as the I/O pack--it is probably the Controller's view of the EGD exchange that is out of date.

Worst case, you could do a Compress Distributed I/O (from the Device->Compress menu) and rebuild and download everything. If that doesn't fix it, I'd submit a PAC case to GE.

Hope that helps!
For future reference.

We are not sure what change happened during the original download or why it happened. Theoretically someone could have changed a parameter days, weeks, months or up to about 2 years ago but just didn't download and that's why during the recent download the PSCA was automatically checked and downloaded. Anyway, we were able to see in the log that the PSCA pack did, in fact, download even though there was no intent to do so. There was a backup file created. Unfortunately the backup file was the new version with the faulty PSCA info so when we tried to revert to that it just continued to download the faulty PSCA parameters. However, luckily there was a copy of the original code from about 2 years ago that was in a zip file created when we had our HMI PC's upgraded. I was able to copy and paste the appropriate "Distributed I/O" files from that and build/download and that fixed our problem. Honestly, still not sure what parameter changed that caused the problem but reverting to the original cured the issue.

Thanks very much for the feedback!!!

If you haven't already done so, now would be an excellent time to make an Acronis image of the entire hard drive for future reference/restoration.

I also create back-ups of unit-specific directories and files on another area of the hard drive, since the hard drives are so large these days.

And, many HMIs also had 'Tasks' that created back-ups every day of the week, rolling back-ups, that were useful in times like these.

Anyway, good to hear all is back to normal, and, thanks again for the feedback!
Thanks a lot for your feedback,

Just wanted to understand what do you mean by a copy of the original code? I mean it is .tcw file or something else?

And how you are able to copy and paste the appropriate "Distributed I/O" files from it? what is the procedure or method to do that?
I'm curious, were you in a situation where you could not do a controller download?

I highly recommend using some sort of configuration management system for your site. ControlST has an integrated one, for example, that lets you compare versions and look at what has changed. CMS was a bit slow prior to V6 of ControlST, but it now uses SVN and is blazing fast.

I've seen sites that run their own SVN, git, or other repositories and use external tools to check in/out files as well, but compares are not as nice.