Problem with S5 siemens


Thread Starter

Hendra Irawan

I use PLC Siemens S5 CPU 942 for controlling all the freezers in my plant. Often I have a problem where OB1 ( organization Block No 1 ) is lost in the PLC , So I transfer OB1 with my Backup to PLC by PG 740 Siemens and then the PLC can Run.
What noise can make the program lost. I hope you can understand and I will be waiting your reply.
A little more information would be appreciated:
1. Is it always just OB1 that disappears,
2. Is there a SCADA or OP connected that is writing to the PLC. If yes, is it non-Siemens hardware/software?
3. When does the error occur? During run, when power is switched on after a weekend...?
4. How is the battery status?

Peter Kosin

Process control engineer
INEA d.o.o.

Michael Griffin

I have seen a somewhat similar problem with blocks other than OB1 several times. In most instances it turned out to be a software problem
rather than a hardware one. In all cases, the problem occured when the AC power was turned off and then back on.
I have seen two software problems. The first was a simple case of a program mistake over-writing parts of the program (this is possible with an S5). The parts being over written were not critical sections so the problem would not be detected until the PLC was powered up again or switched from 'stop' to 'run' (this is when it does a memory check).
To check for this situation, look for any occurances of the TIR or TNB instructions. These write to absolute machine addresses, not to the
normal 'S5' addresses of flags and data blocks. If you find any, you will need a calculator and processor manual to figure out what they are doing. Using these instructions in a normal PLC program is usually a very bad idea as it makes it unreadable and unmaintainable.
Another type of software problem was when a data block was much larger than the normal size (i.e. several times larger than 255 words). I
don't know how this situation came about. We simply erased the block and created it over again in the proper size and the problem went away. This was with a 944 CPU.

A hardware related problem occurred with a 945 CPU which would lose its program when the power went off and then recovered slowly or
erratically. We put in an on-delay relay contact to control the AC supply to the PLC CPU power supply to prevent it from turning back on until the power had recovered for several seconds. We did this one a little over a year ago, and the problem has not recurred.

All of the above occured when the power went off, and then back on. A good test to see if it was a software or hardware problem was to see if the problem also occurs if the mode is changed from 'run' to 'stop' and back to 'run'. If a run-stop-run mode change produces the same fault as cycling the power, I would first check to see if this is a software problem.
If none of the above seems to fit your situation, then if you could give us more information as to what symptoms you see, and under what circumstances you see them, then I believe that I or someone else here could
help you.

Michael Griffin
London, Ont. Canada
[email protected]

D.C. Pittendrigh

Hi All

It is fair to presume that if only OB1 has to be reloaded, that the rest of the program is intact after the problem occurs. In this case it is unlikely that a hardware problem such as faulty ram is causing the problem as such a fault
cannot single out a specific program block.

I am presuming that the OB1 is calling other blocks and does not constitute the entire program.However if this is not the case and loss of OB1 means the whole program is being lost, then it is very likely that the ram on the CPU
is faulty. This could be the on board ram, or the plug in ram card.

In the first case it is possible that software on the PLC could be intentionally erasing OB1, an experienced programmer could write such a program but it could only be written in a FB not an OB, so if the program contains no FB's this is not the case.

Either way the loss of program would not be happening if it was stored on an eprom rather than ram, and after the plant has been commissioned and is working properly, this is where it should be.

I would recommend the following steps :

1) Change the backup battery in the power supply unit.
2) If this does not solve the problem, change the plug in ram module or put the program on an eprom.
3) If the problem is still not solved change the CPU.
4) If this does not solve the problem, then buy me an airticket, and I will come and sort it out for you !!

Feel free to contact me directly if you require further advice.

Donald Pittendrigh
[email protected]

Slawomir Telman

This is a very big problem, however ...
It's good to check it:
- backup battery on your PLC - manual , chapter "power supply modules".
(the PLC lost all program block, after next runing exist standard function block {OB, FB}- change battery if necessary);
- power supply (DC and AC for CPU - maybe momently lost power supply)

I hope this information is helpfull to you.

List Management Account wrote: