Citect Scada 2016


Thread Starter



Recently, while working in Citect Scada 2016, two issues have popped up that I haven't been able to resolve, mainly,

1. Strings entered into text boxes linked to Unity variables will no longer hold their values, despite previously doing so, and show the entered value for maybe a second before going blank. Of the two issues, this one is the more minor.

2. The second issue just started on Monday, and is somehow consistent across 3 Citect workstation despite none of them having internet access or being connected to each other. The issue is that whenever I try to make any changes in Citect's Graphics Builder, I get the error,
"Cannot find the library (library name).symbol. The library may have been deleted or renamed. Do you wish to change the link?" Along with the options of yes, no, and cancel. Selecting yes leads to it asking where the new symbol is, which I am unable to locate, while selecting no removes all trace of the symbol from Citect, and the popup will keep coming up with more and more symbols missing. I tried to select no, and just re-make the symbols missing, however when I tried to compile hundreds of compile errors popped up, despite the program running fine before making the changes. Selecting cancel just closes the Graphics Builder. If I select cancel and run the project the symbols load just fine, however when in the Graphics builder Citect doesn't seem to be able to find them.

Any suggestions would be much appreciated.

For your question I describe as

1. If you use OFS OPC server I have heard that there are same problem as yours maybe you should update your OFS version.

2. Please go to graphic builder select Tools and use Update Pages then compile project again. If you still have error you should check that your symbol library are in project folder (C:/ProgramData/Schneider Electric/Citect SCADA 2016/User/<current project name>).