ABB IT800xA Licensing...


Thread Starter


Our system is a standard ABB IT800xA installation with 2 redundant Connectivity Servers and 3 Aspect Servers managed by 2 domain controllers. The Aspect Server 1 is the License Server. When i check the License Status Viewer, at the bottom status bar, it says "License Client received invalid response from CLS". And i have checked the Apsect Server 1 is selected as the License server. Also i have checked the network connectivity as well... all the services are running normally...

Request help...
Sorry, there are so many possible causes that you are going to have to work through this with the ABB support line. (The answer in the end is likely a small but simple error.) However, you could check the following...

Have you installed the license server and client components correctly?

Have you checked the license client for error messages on every machine in the system?

The License server uses ASP. Read the installation manual guidelines on setting up the license server and ensure that your web server settings are correct.

What version of xA are you running? Are you able to open Control Builder, Graphics builder, etc.? In later versions of xA these need a license to run correctly.

Check RNRP is configured correctly - RNRP is NOT optional even if you have a non redundant network.

Check your TCP/IP network setup and firewall settings.

Have you got a license for every feature installed in the system? Have you got enough tags and CLPs in your license? ABB may be able to supply you with a temporary license with every feature enabled which can get you going while you resolve this issue.

Good Luck.



Emaad ud Din

Thanks rob for your reply. I will definitely check all the points that you have marked. However, the control builder and Graphics builder are working properly. The problem started on 3rd Jan 09. The system has been running normally since Nov 07. At the moment AS1 is the licensing server but if you run the license status viewer on AS1 it shows the same error "local applications running on temporary license" even though AS1 is granting the license to the Engineer Station and all Operator Workstations. I am confused at why AS1 is not grating itself the license for 800xA.

We are running 800xA v4.0 at the moment. I appreciate your help in the matter...

Thanks & Regards,
Remember there is more than one license. Each "feature" in an 800xA system has a separate license. You get all the licenses you have ordered in one .sla file.

The error message "local applications running on temporary license" can indicate that you are either using a feature that you are not licensed for or that the security dongle has failed.

Have you added more logic in the controllers or more objects with faceplates in the 800xA system? This will increase the tag count and may cause you to go over the license limit.

Are you using any Paper Machine controls? I have seen problems with licensing QCS workplaces because these are licensed differently than the rest of the 800xA system.


Hi guys;

Actually we are having different problem in our power plant as below:
We received on the OP3 station the following error message: '' CLS server communication error''. This error message came before every two days once, we had acknlowledged this alarm, and it was so far ok. But again, every half an hour we received this message, we tried to restart the engineering station PC, but the system did not start. Now the OP3 station is out of order and not functioning.

Please advice..
What do you mean by "the system cannot start" ?

Do you mean the PC or windows will not boot correctly? - If so, you have a PC problem. I hope you have good backup/restore procedures or you will need to rer-install from scratch.

Do you mean the System Status Icon on the task bar remains red ? - If so, it sounds like a network or communications problem. See previous posts, check your RNRP setup, network cards, routers, cables, ping times etc and call your local ABB support.