KEYENCE Ladder Builder


Thread Starter

Carlos Renan

Hello, I have installed ladder Builder for KV Ver. 1.50 on a Windows XP professional and it works well on PC but when I intend to upload current program or to download any program to PLC it just appears a screen with text " Communication error occurred. Check for Communication Setting and Connection Lines" Is this problem due to newer Windows version? or do I need to un-install Windows XP Pro and install Windows 95? By the way, I made 2 different comm. cables direct and inverted type.

Thanks in advance.
Carlos Renan

bob peterson

hard to tell. that is the kind of error you might get if you have the baud rate or other parameters set wrong, used the wrong cable, had a bad port, or the port was in use by some other program already.

there are probably a bunch of other things it could be as well.

do you by any chance have RSLinx installed? if the port was used by rslinx you need to uninstall the driver using that port in rslinx and reboot the computer. rslinx has a bad habit of not relinquishing control of a serial port when it is no longer in use.

I can tell you a few things as I use this software frequently to maintain some older Keyence KV PLCs (predating the visual KVs):

- I have used it in XP Pro (32 bit) on many machines with a "real" serial port (PCI plug in serial card).

- I have successfully used it with a "real" serial port and a windows 7 64bit machine with Virtual PC (XP mode).

- I could not get it to work with a USB->Serial port under virtual PC (Didn't try it for the real XP machines).

Just as a side note, we purchased a copy of the KV software through the USA distribution and it installed fine on Windows 7 64bit. It would not talk to the older KV PLCs. Since we have many of these in production I sent the software back. It was very bizarre because the software is not advertised in the USA and they made me sign an agreement that I wouldn't ask them for support if I somehow got ahold of a PLC that they don't sell in the USA since the new software can talk to these newer PLCs. I know that kind of thing is not uncommon for a Japanese company, but I was disappointed with Keyence. The fact that they have been happily selling us these old PLCs and haven't developed a new software to talk to them since 1997-1998 is sad. < END RANT>

I hope this helps.


Ken Emmons Jr.

I just realized that the second paragraph in my previous post was unclear:

" Just as a side note, we purchased a copy of the KV software through the USA distribution and it installed fine on Windows 7 64bit. It would not talk to the older KV PLCs. " ... etc.

Just to clarify, the software I purchased that got sent back was a newer software that Keyence uses with their current KV visual "brick" PLCs (KV16, KV24, KV40) as well as their much higher end PLCs that can be seen on foreign websites (such as the Singapore website). This is why I had to sign the agreement. Note that they still have the old PLCs listed on the USA website. We've been using the new visual KVs lately but since I have to support both old and new it doesn't make sense to upgrade the old software since I have to have it installed in a virtual XP environment anyway.


Calvin Smith

Good afternoon Carlos

I had the same issue on a XP system.
Our keyence got me this.
See if the instructions below help. I am waiting for a response from Tech Support (they are in a training meeting) but this may help in the meantime. I also posted a link below for a free trial version that may be newer than what you have. When I have more information I will give you a call.
Running KEYENCE Programs in Windows XP

As you may know, programs such as KV Ladder Builder for Windows, BL Setup Software, and N-400 Setup program were originally programmed for use on Windows 3.1, '95, '98, and Me. However, Windows XP has now become the standard operating system for a majority of companies. Listed here is the procedure for getting our programs run and communicate with our hardware under the Windows XP operating systems.

1.) Right click on the shortcut for the program and choose Properties

2.) On the top of the properties window, click on the Compatibility tab.

3.) Check "Run this program in compatibility mode for:" and select "Windows 95" from the drop down menu.

These steps usually help the program run and communicate with our devices. Please note when using a USB to serial adapter, the customer may run in to additional communication problems. We recommend using the KEYSPAN USB Serial Adapter (model # USA-19HS).

See also USB Adapter Notes

We also downloaded the new version of the keyence software from the web site. Version 6.0 I think.

Hope this helps
Dear Calvin

I"m still having problems with my older keyence KV40R.

I'm using a laptop (no serial port) with a USA 19HS converter with XP pro 32 bits in VMware player in a win7 Host 64bits

The Keyspan serial assistant says everything is OK,
I see the converters green led flickering when working but I keep getting the "communication error occurred" message.
My cable should be OK since it works on my older desktop with build in serial port.

Can you tell me what settings you use
or any other tip is welcome

The Run LED gets turned on through the programming software after download, or when you cycle power.


stefan haesen

Then I first need to be able to program.

I just installed vmplayer 3.1.6 and XP installed ladderbuilder

When I look in VM in device manager I see COM1 and COM2 and LPT1.

In W7 the keyspan driver is installed.

When I plug-in de keyspan, XP is asking to install a driver. I haven't done this yet but in device manager I don't see an extra com port. Under "Other devices" I see the keyspan USA 19HS with a yellew question mark.

In Ladder builder communication settings I can only choose between COM1 and COM2

What should I do next?

PS I believe I had the PLC programmed a few years ago but I left it stored without power. Could it be that the device won't retain its program for so long?

Ken Emmons Jr.

VMPlayer is intercepting the USB device and the guest OS (virtual XP) is getting the USB port and wanting to install a driver. In my applications I have not enabled my USB serial on the virtual device.

There should be a setting in VMplayer to allow or disallow particular USB devices to be taken over by the virtual machine. I tend to do all of the device driver installs on the host OS (Win7 64bit) instead and use the COM port pass through feature of the VM.


stefan Haesen

Dear Ken, Sorry for the trouble.
Can you clarify this pass trough feature?

In W7 device manager :ports: I can only see: Keyspan USB serial port(COM1)

In VM>XP>device manager I have communications port (COM1), communications port (COM2) and printer port (LPT1)
I have no idea what ports com1 , com2 and lpt1 are.
my laptop only has 3USB ports.

Now, in VMplayer: menu "virtual machine>removable devices", I can select "keyspan USA19HS" to "connect(Disconnect from host)"
If I do this, XP requests a driver.

If I don't install this, nothing changes and I can not program my plc with Com1 or 2. The keyspan doesn't even react
If I do install the driver a new com port appears in device manager but it has number COM3 which I cannot choose in ladder builder. When in device manager I Swap COM1 AND COM3 the keyspan reacts when programming the PLC but I get the communication error message.

Or is the pass trough feature something completely different.
Please tell me in detail what to do.

Thank you very much

Ken Emmons Jr.


The way I did it was to keep the USB converter (Keyspan in your case)connected to the host. So in other words, don't enable " select "keyspanUSA19HS" to "connect(Disconnect from host)"". Then there should be a setting in VMplayer to map the guest COM1 to your host COM1. Don't assume they are mapped 1:1 or that they are assigned at all. You could,in fact, map Com4 of your host (win7) machine to COM1 of the guest OS. I happen to have my USB converter on COM1 of both host and guest as this works best with all the various software I use. So find somewhere in VMPlayer that has a setting for the virtual COM ports, that should be your first task.

Again, I am using Virtual PC with XP mode image downloaded from Microsoft, I've not tested with VMWare or virtual box. I am pretty sure I got the keyspan device working at one point, but I'm using a startech FTDI based device now (I liked the cable and packaging better on this one). I'm guessing its not an adapter problem, but the fact that your guest OS machine configuration is not right (see above paragraph).

BTW, do yourself a favor and connect to another serial port or known good serial device FROM YOUR HOST MACHINE FIRST. Is you use serial terminal software like hyperterminal you can send characters back and forth. This way you know the port, cabling, and setup is working on the host and then do the same thing from your guest OS, i.e. virtual XP. Make sure that you don't have the serial port open in the host while the virtual machine is running!!! Think of the serial port as being shared between applications, where the virtual machine happens to be one of them.

It gets to be a nightmare to try to explain and think about, especially if you are new to virtual machines, but I hope I've helped a bit here.Our boys at Keyence have left us old KV guys in the dust since 1998 as far as the software goes. I'm a bit frustrated that they continue to sell the old KVs (and the new ones for that matter) with the ancient1998 software. How the heck can they justify this? We've since switched from Keyence for our small applications to the Mitsubishi FX3G. mostly this was because we have experience with the larger Mitsubishi PLCs (I'd probably look at OMRON if we were to start over from scratch with a brick PLC, or maybe just go to a system like B&R and find the room to house the thing in a larger enclosure).

BTW, are you using an old KV, or the visual KV with the LCD on the front? The reason I ask is that if you don't have to support the old"non visual" KVs then there is a software available that runs on windows7 even in 64 bit OS for the new visual KVs. You have to ask the guys inthe USA about it and even sign an agreement that you won't expect support from Keyence USA. I think I had to download a trial version from the Singapore website because the US website doesn't even mention it.


stefan haesen

Dear Ken

I tried VMware, virtualbox: no luck

Then I've tried setting up a dual boot: pure horror. This ended up in a recovery.

Now I Have set up the windows virtual PC with XP mode just like you.
Can you please tell me in detail the steps I have to take to succeed.
If this doesn't work, a PLC will be airborne :)


Look back in the prior postings and do the steps I had already pointed out. If you are still going at this I think you should invest in a $100 windows 2000/XP laptop with a real serial port and use a flash key to transport your files back and forth.

I decided to discard the Keyence PLC. it took me about 20 hours to get zero result. Thumbs down for keyence.
I got me an old Omron CQM1 and in less than 5 minutes I got connected.

Special thanks to Ken for the Support. If you like classic music: Sit back and enjoy the intro of
I've not used OMRON but I understand the software is nice. I had assumed you were stuck programming Keyence for already installed projects, otherwise I would have recommended other manufacturers.
after rewiring a complete machine for a friend and programming the PLC 4 times, I went to change a timer and got the comm error. the plc run error light went off and I never got communication restored. after several hours I had the same problem and threw the KV-16R in the trash. An AB 1000 now runs his machine with no problems. If you see an old Keyence PLC!
I don't think this is particularly fair. I certainly don't agree with the software support that Keyence has left us with, but if you run the software with the OS and hardware it was designed for it works well. I maintain over a dozen machines with KV-16/40 PLCs and I have been able to use the software with an FTDI USB-serial and Virtual PC running the Microsoft XP image just fine. We also have older desktop machines running XP natively with PCI plug in serial cards that program these things just fine.

Well thanks for the positive report. I have been trying to communicate with a KV10T for a week and Tech support is no help. they had me buy a cable that didn't fix the issue. Running WN 2000Pro. The software is 1.5 ladder builder like all have been discussing. Changed port parameters and no help. Tried to run it in compatibility mode but there is no tab for it in the properties menu. The idea that another driver is held to the port is intriguing but not sure how to find it. Any suggestions would be greatly appreciated.