Mark V HMI No Data


Thread Starter


<p><b> Current Setup </b></p>

Four Gas Turbines {GT1, GT2, GT3, GT4} each with its own (HMI,Mark V and exciter) + one extra "<i>Master</i>" HMI in the control room.
<p><b> Connection </b></p>

There are three different connections:

1- Stage Link: which is the "<i>ARCNET</i>" connected in a bus/daisy chained as follows..<pre>
A coaxial cable goes from Master HMI to GT1 HMI using a T connector.
Then from GT1 HMI to GT1 Mark V. Then from GT1 Mark V to GT1 Exciter.
After that it goes to GT2 HMI... then GT3... and GT4 in the same manner.</pre>

2- PDH: which is a star fiber/Ethernet network that goes from the master HMI to each GT HMI using a separate switch in each GT.

3- DCS: which is the serial connection from each HMI to the DCS.

<p><b> Symptoms </b></p>

GT2 data can't be seen by GT2 local HMI. However, other HMIs (including the master) can see GT2 data.
Moreover, GT2 HMI can see some others (<i>GT1,GT3, GT4</i>) data. At the same time DCS can't see GT2 data.

If the coax cable coming from GT1 (<i>Exciter</i>) to GT2 HMI is disconnected, GT2 Data comes back in GT2 local HMI and DCS.
In this case, previous HMIs (Master, GT1) can't see the remaining (GT2, GT3, GT4) which make sense since they are isolated.

<p><b> Additional Information </b></p>

When I type "<i>arcwho</i>" command in GT2 HMI during normal connection, only four addresses show up + the local address.

{My address: F2
Nodes found: F5 F1 31 01}

After disconnection, nine addresses show up + the local address.

{My address: F2
Nodes found: FF F4 F3 5B 4D 3F 2B 1D 0F}

Another thing found in GT4 ToolboxST is that GT1 & GT2 have the same secondary proxy which is GT2. This was corrected but nothing changed. (I believe this might lead to incorrect data but not to "<i>No Data</i>")


<i>I'm sure that I'll find the answer in this wonderful forum.
I really count on you, specially on the Genius CSA.</i>
When did this problem start? After a DCC/SDCC replacement?

Was there some problem with the GT2 HMI CPU that caused the software to be re-loaded on the HMI?

When was the last time the HMI CPU case was opened and vacuumed of dust/dust bunnies?

Have you tried using the Logic Forcing Display to see if data values are coming to the HMI? If you can see data values using Logic Forcing, then the problem would seem to be with CIMPLICITY. If data can't be seen using Logic Forcing, then it would seem to be a hardware problem--either the coaxial cable, or the BNC tee connector. Sometimes the BNC connectors can become corroded and not make good contact.

Very often, if coaxial cables were fabricated on site during installation the quality of the crimps was very poor. Also, sometimes, the wrong cable type was used--it worked for years, then just became intermittent or just stopped working. Also, there have been problems with BNC termination resistors failing, as well.

But, we don't have enough information because it's usually found when troubleshooting these problems that something else was done which caused the problem. Either a hard drive was replaced, or an ARCnet card was replaced, or a DCC/SDCC card was replaced, or a CIMPLICITY project was copied from another HMI,and some step was not properly done that cause the problem on a previously working StageLink. It could be the the StageLink ID was not set correctly, either on the ARCnet card, or in the TCI Control Panel applet, or on the DCC/SDCC card.